No audio device found after Wake On Lan

Hi @support

I used an old laptop to run Roon Core. I was able to wake the laptop with Wake On Lan. Worked fine. I had to switch to a more powerful laptop (I’m going to use DSP) and installed an HP Elitebook 840G1 to run Roon core and configured it to be able to use Wake On Lan. Now I have the following problem:

  • The Laptop receives the ‘magic packet’ and wakes from sleep (the fan starts running, the keyboard lights up and Roon Remotes connects). The screen of the HP laptop stays black/ off.
  • I can verify that Roon Core is running: I can see my collection on the Roon Remote.

One big problem: I get the message ‘No audio device found’ on Roon remote. After I touch an arbitrary key on the HP laptop, the laptop screens starts working and Roon remote finds the audio devices!

What I tried already (but didn’t fix the problem)

  • I tried the steps from this website: So updated the bios, disabled hybrid shutdown, checked again whether wol on for the lan driver was enabled, and changed the registry as instructed
  • I tried the energy schema ‘max performance’

Can someone please support how to fix this?

2/2/2019: important update
I found out that WOL from hibernate does function correctly. Unfortunatly, this is no structural solution (takes to long to start up). When using WOL from hibernate the laptop screen is also not blank but is directly active. So: active laptop screen = Roon works correctly?

Some details

  • Most recent version of Roon is installed
  • Using windows 10 64 bits
  • Using a Laptop Elitebook 840 G1 (connected via LAN cable)
  • Music stored on Synology NAS

I’ve got exactly the same issue. I have posted already some time ago [No sound under roon after waking up from sleep mode], but we closed the matter, as it was working again all of a sudden, but unfortunately not for long.
I didn’t bring it up again, because I think it’s something weired with my system, so I’m quite happy, I’m not alone :slightly_smiling_face:. Maybe there is a solution after all. I’m at work right know, but would be happy to provide more information if necessary.


Hi Tobi, thanks for joining this discussion. I hope a technical guy from Roonlabs will join the discussion. I think in my case, the wake on LAN doesn’t wake the computer for the full 100%. Maybe I have to change a setting in the energy scheme. The question is, based on the described behavior, what aspect might be still ‘sleeping’ after wake on LAN. Obviously, the network functionality is working (otherwise the core wouldn’t be visible in the remote) so what element can still be ‘sleeping’ so no audio devices are detected?

Hello @Sander_vg,

It sounds like the WOL from sleep is not properly enabling the Roon audio devices. You might want to check “Energy Efficient Ethernet” settings to see if that helps or “Fast Startup” in Power Options. Are you using the newest Audio drivers for your Elitebook? This thread may also be helpful.


A post was split to a new topic: Windows 10 - Missing Audio After WOL