"No audio device found" and no sound. Roon worked fine for months until now

I changed no settings, but about a month ago I began getting this message and no sound. My separate TIDAL app and all other audio work perfectly. I cannot get Roon to make a sound.

I’m on Windows 10 PC running through an internal Juli@ DAC. No other programs are exhibiting any audio issues whatsoever.

Hi @E41Hz ----- Thanks for the report and my apologies for the troubles. May I kindly ask you for the following information to help aide in my evaluation of this issue. Please see below. Thanks!

  1. I see that you are running your core on a Windows 10 PC with an internal Juli@ DAC, can you please expand on this information a bit more and give us some more details of your setup as seen here.

  2. Have there been any updates to your OS, firmware, or audio drivers recently?

  3. Can you please provide screen grabs from your “audio” tab found in settings.


Here are additional details:

  1. Windows 10 (64 bit) custom built desktop (Intel i3 @3.30GHz, OS build 14393.321). My library is stored on a separate internal drive (not my C drive) but accessing music is not the issue; Roon accesses and plays my sources (8000+ tracks in library, and TIDAL) but no audio is delivered.

  2. Windows 10 is on auto update. There have been updates to the OS since this situation developed. There have also been updates to Roon as well. I cannot pinpoint the date this first emerged, but I it was around late August.

  3. Screenshot of “audio” tab is below. The multiple zones for Juli@Audio were a result of my attempts to fix this issue.

  4. I’m not sure this is related, but if I minimize Roon on the desktop it will restore to a plain white page and will not be accessible.

Again all other programs deliver perfect audio. I can go direct to TIDAL with no problem, but I would prefer to have my music and benefits of Roon! Thanks for any help you can offer!

Hi @E41Hz ----- Thank you for the follow up and taking the time to answer my questions. Both are very appreciated!

  1. Can you confirm that the drivers for the Juli@ DAC are up to date?

  2. I see that you have the WASAPI audio driver engaged under your “Audio” tab, does using the ASIO driver change any behavior here or is it the same results?

  3. I apologize if I am missing this point and if you are having to repeat yourself, but to clarify, you do not get any sound out of roon, not even through your OS’s mixer to the internal speakers, Correct?

  4. In regard to the window restoring issue, how long does this usually sit in this state, “white page” screen? What usually fixes this? I am assuming, re-launching the program. What type of graphics card are you working with in your setup?


Thank you Eric. Using your suggestion to switch to the ASIO driver gave me back my audio. It’s odd because I was not using that setting previously before this incident and things worked fine. However, the issue pertaining to #4 is still happening.

Still it may be helpful to the community if I answer your questions:

  1. Yes, Juli@ DAC driver is up to date. No update is available

  2. Changing to the ASIO drive WORKED! Audio from Roon has been restored to my system.

  3. I did not get any sound out of Roon regardless of whether I accessed tunes in my library or from TIDAL. I got perfect sound from all other programs I accessed not from Roon. Programs such as Spotify, TIDAL worked fine when I accessed them directly using their apps or programs (again, not using Roon to access them). Websites such as YouTube also provided audio perfectly. The issue clearly was with the Roon setting and not with the OS mixer. (For the record, I am feeding my audio signal to the Juli@ DAC to an Arcam amp powering KEF LS50 speakers. Quite wonderful.)

  4. If I minimize Roon, upon maximizing the “white page” screen will stay that way…white. No response Forever, perhaps. The only action that remedies the issue is to re-launch the program. Unfortunately I don’t recall which sound card I installed; it’s probably three years old.

Hi @E41Hz ----- Thank you for the follow up and glad to hear music is back :tada: In regard to “#4”.

“If I minimize Roon, upon maximizing the “white page” screen will stay that way…white. No response Forever, perhaps. The only action that remedies the issue is to re-launch the program. Unfortunately I don’t recall which sound card I installed; it’s probably three years old.”

This is actually a known issue that we have seen before:

Roon uses a custom graphics engine, like a video game. This engine is based on OpenGL, which is what allows Roon to provide identical functionality on so many different platforms, and what allows a team of our size to develop for so many platforms.

We depend on OpenGL to render our interface, and in turn, OpenGL depends on your GPU’s drivers to let Roon know when the interface needs to be redrawn. We have seen some graphics drivers have issues with this (Intel in particular, especially with older models like the 3000 and 4000) and we’ve seen this driver weakness affect many other applications, including widely used applications like Outlook and Photoshop.

Unfortunately, this leaves us with few real paths forward. We have seen times when Intel releases an updated driver and the issue goes away completely, which obviously would be a nice solution here. Some Intel drivers seem to work decently (including affected GPUs on OSX) and some appear to have significant issues in how they communicate with OpenGL and the applications that depend on it (like Roon).

In systems with multiple GPU’s, we’ve seen improvements when people “force” Roon to use the non-Intel GPU, as described here. We know that’s not an option for everyone, but it has helped some of the maybe 20 or 30 reports of this issue we’ve seen.

There’s nothing we like less than saying “we can’t do better” but unfortunately in this case we are the mercy of the driver.