No audio devices found [solved - subnet change triggered by power outage]

Roon Core Machine

SonicTransporter i5 ver 2.7
Roon 1.8 (build 806)

Networking Gear & Setup Details

eero mesh network
can provide more details if needed

Connected Audio Devices

Optical Rendu ver 2.8 ethernet/optical/usb
BlueSound Pulse wifi
BlueSound Flex wifi

Library Size

25K tracks

Description of Issue

No audio devices found error. Audio tab in settings completely blank.

Hi @David_Frantz, it’s good to see you on the Community again - sorry for the issue though!

Let’s start with making sure all your devices are on most recent firmware, then reboot your Core and all your devices simultaneously

Also, can you provide the extra details on your network setup? In particular, we want to be sure all your devices are on the same subnet.

Hi Kirsten,
Thanks for helping. All devices are up to date. Did a more or less simultaneous reboot of the machine running the core, all endpoints, router, and switch. Didn’t help.

Router is a Fios G1100
Switch is a Linksys SD205
Eeros mesh network.

I can see all the endpoints on the network, but Roon doesn’t seem to see them.

What should I try next?


In addition I’ll note that Roon doesn’t even seem to be able to play from the device being used as controller. In other words I can connect to Roon from both my iPad and iPhone, but neither shows up in audio devices. I still get “no audio devices found”.

Thanks for those details. Do you have multiple networks or subnets in your configuration? Roon doesn’t support multiple subnets, so that could be one possibility here. To be more specific, If the Core’s IP address is all the other devices need to match except for the last set. So in this example, 192.168.1.X is acceptable, but not 192.168.2.X

Let me know what you find here, please!

Thanks Kirsten. I don’t believe I have any additional subnets. Everything appears to be 192.168.1.X.

Do you see your devices in the “Settings” “About” tab?
If so, do you have the option button to “enable” them?

Wait! I was wrong! All my endpoints are on 192.168.7.X, while my core is at

This is obviously the problem! The system has worked for years without this issue, but we had a power outage the other night that must have mucked things up.

Can you help fix this?

Got it sorted out. Thanks for your help guys!

I’ve had this problem from time to time with power outages. Solved it permanently by assigning a static IP address for the Roon core machine (sonicTransporter-AP i7) in my router’s settings.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

That’s great news @David_Frantz! Sometimes it’s the tiniest things :laughing:

And thanks for the input @wkimbel87 That’s helpful information to share.

We have also just published a quick guide on this topic. If anyone wanders through here with a similar issue, take a look at this: Checking for subnets.