No audio from Sennheiser Ambeo Soundbar via Airplay

Thank you! I hope they know s fix.

Hi @Eddie_Hsu ,

Thanks for reaching out! Can you please try the steps listed in this KB article on your device? Even though you have a different device, the steps should be similar:

If this does not work, can you try to add an Airplay password and see if that helps? Also, if you wish to group multiple zones, you can try to play to an iOS device and then use iOS to forward the Airplay to the Ambeo.

2 Likes

Thanks for your reply Noris. But Home app could not find my Ambeo. Weird~ but I can see it on my iphone as an airplay device if I stream from the phone. I can use ios device to stream but music stutters. Connection not very stable.
How do you add airplay password and where? Sennheiser app has very limited function. Only reset airplay :frowning:

Hi @Eddie_Hsu,

Unfortunately, the only way to add an AirPlay password is via Apple Home. I was a part of the testing of the device featured in the article Noris provided. During my testing, I couldn’t get Apple Home to recognize the speaker. I had to create a new room and then add a new accessory. Give that a try and let me know what you find. Getting it working with Home will be key to getting it working with non-Apple native setups like Roon.

Thanks,
Wes

1 Like

@Wes I tried but still no luck :frowning: Home app still do not find Ambeo in the new room I created :frowning:
Roon clearly see Ambeo soundbar with either chromecast or airplay but only able to stream to it via chromecast for some reason.

Hi @Eddie_Hsu,

I wish I had more to suggest. My last thoughts are that the soundbar may need to be on wifi in order for your mobile device to find it within Apple Home but I’m not certain. Also, ensure the soundbar’s firmware is up to date. The Apple Home app should be able to see anything relevant to airplay and the fact that it’s not seeing it is concerning.

I’m also hoping others might see our post and chime in with other possibilities.

Wes

1 Like

Hi @Wes;
The firmware is the first I checked and it is up to date. I’m not sure why Apple Home app does not see the soundbar but my iOS devices see it and roon see it too ( just roon not able to get sound out of it :frowning: ). Btw. Home app does not see Sonos either although roon see the airplay feature of Sonos and could play to Sonos. Can you explain why roon sees the Ambeo as airplay device but not able to stream to it? Is it because roon can not make Ambeo to switch to airplay?

Cheers
Eddie

My understanding is that it’s a matter of authentication. Roon (being SW) is not an Apple product. With the Cabasse product above, it’s this authentication that facilitates the connection. From an iOS device, no authentication is necessary since it’s an Apple product. I may be wrong though I’m almost certain the absence of it in Home is relevant.

Tomorrow I have a reminder set to talk with our product testing team and see what they think. In the meantime, I would be interested to know what their support thinks of your inability to find it in Home.

Wes

Hi @Eddie_Hsu,

I have an Ambeo Soundbar, and it plays from my core and Roon remote without issue. My core is Windows 11 and the remotes are an iPhone 13 Pro Max/iPad Pro. First, have you done the steps in this post [Set device permissions in the Home app.] ?

When I installed the soundbar, Roon created the “Default Room…” AirPlay device in the image below. To see if adding it as an accessory in IOS as suggested by @noris, I tried it and it worked; it created the second device labeled “Ambeo” in the image below.

Connection infol:
The soundbar is the primary speaker for my AppleTV. I have an HDMI cable running from the AppleTV to the soundbar, then back to my TV. The soundbar is connected to WiFi.

Hope this helps.

Thank you Steve. Its so weird mine does not work. I primarily use chromecast to stream music from roon ROCK to Ambeo. I wonder if that is the problem? The other difference with your set up is that I connected Ambeo with ethernet cable. Wifi is not set up.
roon tech did suggest me to add Ambeo in Home app but the app could not find Ambeo :frowning:
I will try to set up wifi on my Ambeo to see if that solve the issue. I will report back

Hi @steve_smith1;
I tried 2 things just now:
1, I factory reset Ambeo. Still the same issue. Roon found 2 of it via airplay. I enabled 1 by 1 but still roon was not streaming to it. I can see the file conversion map but music not playing.
2, I unplugged ethernet and set up wifi but the same result as above.
I can not see Ambeo on Apple Home app and tried add assessory but still could not see Ambeo. Google Home app found my Ambeo though. However, my iphone, Mac and iPad can all play music to Ambeo via airplay. The only problem is roon can not stream to it via airplay!
Is this roon problem or Ambeo problem? However, I do think its more to do with roon because iOS devices can stream to Ambeo under airplay.
Does this issue having anything to do with me using roon ROCK?
Cheers

Eddie

Hi guys, problem solved! I have to go to iOS setting and find Home app setting and set my ipad to be Home hub then I can find and add Ambeo and others as accessories. After that, roon streamed music to Ambeo via airplay successfully :slight_smile:
Happy! Thank you all for your valuable tips to get me here.
Eddie

5 Likes

This is GREAT. Thank you for the update, Eddie. I will put this in my back pocket for future users with the same problem.

Wes

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.