No Audio from Spotify

Hi Folks,

i just set up my second RoPieee, this time with XL.

I just crashed into an issue:

I ran roon on my Pie in the Kitchen and my girlfriend wanted to switch to spotify but roon ist still running even though spotify signals its connected to the Kitchen Pie.

I stopped roon and the error still persists, no Audio from spotify.

After a reboot I play music via the RoPieee.

Is this a known issue?

Both services want to lock the audio device on the Pie.
This means that if you’re playing via Roon you can’t use Spotify (or DLNA / Airplay for that matter).
Even after you pause audio on Roon it will take some time before the audio device is unlocked and you can switch to Spotify.

Have you tried using Spotify directly after a reboot? So without first using Roon?

That’s what I thought… :wink:

Do you know how long?

Maybe this could be a feature in the future - choosing how long the service blocks the audio output?

Sometimes I quickly want to switch between roon and Spotify…

Now it worked again-after waiting like 10 minutes or so

I believe the issue is with ALSA, the audio architecture/kernel interface in Linux not giving back control. It’s not configurable but usually only takes a min or 3 to let go and let something else send sound.

This is my experience on a Linux machine running both Roon Core and Shareport Sync (for Airplay access)