No Audio from squeezebox Duet, SB2 or Boom

I have thoroughly read all the posts on this topic, to no avail. I am running Roon 1.3 on MacOS 10.12.3. I removed LMS and rebooted the Mac. I reset the Duet to factory settings and restarted that. Roon can see the squeezeboxes, and on the Duet, the controller can see the Roon feed in Now Playing. But there is no output from the Duet or from any of the other SBs.

Any ideas you may have for troubleshooting this further will be appreciated.

Have you rebooted Roon?

Hi Henry,

Yes, I rebooted Roon.

try to post a screen shot of the audio path…perhaps you are upsampling to something the SB’s can’t handle?

Not sure what you mean by the audio path. For the SB Receiver device, sample rate conversion is set to compatibility only. For system output, max sample rate and max bits are set to disabled.

When playing a track click on the signal quality icon (glowing star, purple in my example), which will then display information about the signal path similar to that shown below:

screenshot attached

Hi @John_Egan ----- Thank you for the report and my apologies for the troubles here. May I very kindly ask you to please provide the following information:

  1. A brief but accurate description of your setup as seen here.

  2. Please describe your network configuration/topology, as well as providing insight into any networking hardware you are implementing. I want to have a clear understanding of what the chain of communication looks like in your setup and what tools are being used to make those connections possible.

  3. Please provide a screenshot of the device settings being used.


I provided this information earlier in the thread.

Since the last post, I was able to get the SB2 and the SB Boom to work. Now it’s just the SB Duet Receiver that is not working. As mentioned before, the controller is working, but nothing gets to the receiver itself.

I posted some more screenshots of settings for the Duet Receiver.

Hi @John_Egan ---- Thank you for the requested screenshots, they are appreciated! I see from the information provided in your earlier posts that you are currently working with the following setup:

I am running Roon 1.3 on MacOS 10.12.3 w/ SqueezeBox 2, Boom, and Duet receiver.

My assumption is that these end points are all being accessed over WiFi, is this correct? What type of router are you using? Are there any other devices (i.e networking hardware - switches, extenders, repeaters, power line adaptors) in the chain of communication?

Lastly, in your troubleshooting of this behavior have you tried eliminating WiFi from the “equation” and testing with a hardwired connection via ethernet? Was the experience the same of different?


All network connections are wired, except for the Duet controller. Therefore, only the Duet controller uses the wifi router, which is a Linksys AC router. All the other connections simply go through one netgear switch. That’s it.

At this point only the Duet receiver is not working.

well, I would test to make sure it is not the Wifi settings, by plugging the Duet into the netgear. if it is seen as a wired connection, then we know it is something in teh Wifi settings for sure.

The Duet receiver is already on a wired connection. The Duet controller is a wireless wifi remote and it cannot be plugged into the wired network.

Also, the Duet controller is actually working. It shows the stream being sent by Roon Server. The stream is not getting to the Duet receiver, which is on a wired connection.

Hi @John_Egan ---- Thank you for following up and verifying that information for me. My assumption is that the firmware of the Duet is up to date, is this correct? And furthermore, that LMS is definitely not running anywhere on your network, as specified in post 1?


The Duet has the firmware from LMS 7.9, which is the latest. And I confirmed that LMS is not running anywhere. This issue is peculiar to the Duet, as the SB2 and Boom are both working properly now with Roon Server. I’m not sure this can be resolved.

The Receiver always was the red-headed step child of the Squeezebox line up.

Here’s a couple you could try to assist in troubleshooting:

  1. In Roon device settings, toggle Use FLAC Compression on or off. Try the stream again.

  2. Depending on what setting you had for 1., try sending something other than ALAC to the Receiver - do you have some mp3 or FLAC for example?

I toggled FLAC compression and retried. I tried sending MP3 and FLAC. Nothing works. I’m ready to give up on this.

Hi @John_Egan ---- Thank you for your patience here and my apologies for the continued troubles. Just to re-confirm as it stands now, you can achieve playback via the remote but the receiver is still with out playback, correct? If you turn off the remote, is there any change in the interaction between Roon and receiver?

Furthermore, I did some digging around the community site to see if anyone else was having a similar issue and came across this thread from last February.