No audio on Squeezebox Classic

I’m trying to stream music using a MacBook Pro, Classic Squeezebox and Devialet 200. I’ve followed the instructions from the Roon website regarding deactivating LMS and enabling the Squeezebox in the Roon set-up menu. All seems to be working as expected except that there’s no sound from my speakers.

The Squeezebox display shows Roon logo and spectrum graph indicating music is playing, but no sound. I’ve got the SB connected via both toslink & coax to Devialet.

SB works great using LMS, but since I’ve a lifetime membership in Roon I thought I’d rather use it for obvious reasons. Especially with it’s great Tidal integration.

Any suggestions to troubleshoot the problem? I’ve cycled the power and no luck. Thanks.

Ken Leibowitz

Volume set appropriately for SB?

Volume set to 100 (max)

Did you get this working yet Ken?

Have you tried the analogue outs on the SB, just for troubleshooting?

I’ve been out of town. Will try again later today. Thanks,for your follow-up.

No I haven’t . Great suggestion though. Will try later today and let you know if any change. Thanks Mark.

None of the digital or analog outputs of my SB Classic work with the Roon controller thru Devialet 200. Using Logitech Media Server instead of Roon, and everything works perfectly. The SB display under Roon control shows that music is playing, but no sound. Baffling.

Thanks to those who offered suggestions. Unless a solution is found, looks like I won’t be able to use Roon unless I use USB or another media server. The Squeezebox via toslink or coax sounds much better than USB from MacBook Pro.

There’s a guy who had a similar (non)sounding problem with his Transporter and a factory reset of the Transporter sorted it. Maybe try same with the Classic?

Will do. Thanks again for your help. Will keep you advised.

EUREKA! I’ve finally gotten my SB to work with Roon. What a joy.

Thanks to all who gave advice and support. A special word of thanks to Mark, whose suggestion was the solution. I reset the SB to factory default and that did the trick. Such a simple solution, and yet it escaped me. Typical. I’m now a very happy camper.:grinning::notes:

2 Likes

Nechro bumping this thread to add confirmation and reset procedure.

Yes.

I just did factory reset on a Logitech-era Squeezebox 3 that wasn’t producing any audio on Roon, but played fine on a “real” LMS and it worked fine on Roon thereafter.

To reset the Squeezebox 3, hold down the “+” key on the Squeezebox remote while unplugging and reinserting the coaxial power plug. You will have to reenter your WiFi credentials and possibly the IP of your Roon server. I didn’t have to do any other reconfiguration.

Cheers

1 Like

:+1: The advice just solved my same problem here too. Boom, Radio and Touch didn’t have the problem.

I realise this is an old thread but I have this exact same issue. Just trying the Trial and my Node works fine but the Squeezebox Classic outputs no sound.

I have tried all the suggestions on resetting, LMS is disabled on the Core, Squeezebox support is enabled in Roon, everything “appears” to be working just no sound either via digital out or analogue. Fixed volume or variable makes no difference either.

Any thoughts please?

Thanks in advance…

Start your own thread in the support category.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

ok thanks will do…