No Audio Output Devices..... Roon not listening on Port 9000

Hi,
I installed 1.8 and am running build 783. I am having issues with not seeing any Audio Output devices. Roon Remote is indicating “No audio devices found.”

I am using a 432 EVO Aeon music server which is running Roon Core and uses LMS as the player. It appears that Roon is not listening on port 9000 which is the LMS port. Nothing is listening on that port, so LMS players won’t connect to Roon. See below:
Normal:

[root@vortexbox ~]# netstat -p --listen -n |grep 9000
tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN 5795/RoonAppliance

Your server:

[root@vortexbox ~]# netstat -p --listen -n |grep 9000
[root@vortexbox ~]#

= no output

Any ideas how to resolve this? I tried rebooting the 432 EVO several times, no luck. I also tried Turing off, then turning back on Squeezebox Support in my Roon Remote app. That doesn’t resolve it either. This is the case whether using Roon Remote on my iOS app or the Mac version of Roon software.

Is there a way to force re-install Roon 1.8 Core? Not sure what else to do that this point. Thanks for any assistance/advice.

Jeff

Hi @Jeffrey_Duggan

We have an article on this here:

Can you try what is suggested there? Just to confirm, are all LMS servers disabled on the network?

Hi Dylan,
Thank you for your reply and suggestions. Unfortunately, those troubleshooting steps were not helpful.

To Answer your question, LMS is NOT running on your server. See below server log entry:

systemctl status squeezeboxserver

squeezeboxserver.service - SqueezeboxServer Daemon
Loaded: loaded (/usr/lib/systemd/system/squeezeboxserver.service; disabled)
Active: inactive (dead)

On a server with LMS active, you would see the port being taken by a perl process, which is not the case on my server as you can see:

netstat --listen --tcp -p -n |grep 9000

tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN 26357/perl

From this information you can see that Roon is not listening on port 9000, and LMS is not running on it either, as LMS has been disabled in systemd. The empty output of the netstat command is further proof of this.

Is there a way to force reload the 1.8 software on my server to address any potential installation anomalies? Everything was working fine on 1.7. This problem presented as soon as I installed 1.8.

Thanks for your assistance with addressing this problem.

Jeff

Dylan,
I have not heard back from you. Can you please take a look at what I provided in my last post and provide some direction. Is there a way I can force re-load V1.8 to see if I can resolve this? It is apparent that it is not functioning properly and considering this happened as soon as I upgraded to 1.8, I have to believe this ball remains in Roon’s court to solve.

Please continue to provide help or pass my on to the next tier to get this taken care of.

Thanks,
Jeff

@support.

Any help here?

Hi @Jeffrey_Duggan ,

Yes, this would be a good next step, and you can achieve this by setting the current database aside with the below instructions.

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • Let us know if this helps with the issue

Thanks!