No connection to Linn Klimax

Hi, I’m running Roon on a Innuos mini connected to a linn klimax.
Roon doesn’t find the Klimax.
What can I do?

My Klimax is at a different location so I can’t check right now, but I have a Selekt here and the setup is the same. Go to Settings>Audio on your Roon remote, look for the Klimax and enable it. The Roon core and the Klimax should be on the same subnet, of course.

Which version of the Klimax do you have, and is its firmware up to date?

I have the second generation Klimax DS/1 (software version: 4.79.383), and Roon has no problem finding the Klimax. I’m running Roon Rock on an Intel NUC, though.

By the way, if you have recently powered down a switch or another component on your network, then you may need to re-boot the Klimax (just switch off/on) in order for Roon to find it. This has caught me out a few times in the past.

ROON/KDS user synced the very beginning (and even before the two companies reached an agreement via a Sonore device)

With that said Roon Linn integration has always been, and continues to be, flakey. Just look at the history of the posts.

Do other endpoints work from your Innuos? iPhone as a Roon endpoint - does it work?
ROON Core running on a computer - does it work?
Just some trouble shooting ideas to see if the Innuos is the issue

Nope, four Linn DS‘s here. Never a problem with Roon. Ever.

is it the first time you are trying to connect or was the DS there before and is now missing. Some more details / description might help.

Lucky you. A Klimax DSM and a Selekt DSM (two different locations), both with occasional Roon issues.

It’s the first time,that I can’t find the linn in my room Surface.
I made two updates of my Innuos Server, which is my Roon core.
I think, there is the problem!
So you have an idea, what to do?

Have you checked in Roon #Settings# then #Setup# that the Linn streaming is pointing to the correct subnet?

Some checks you could do:

  1. What’s the IP address of the Klimax system? I don’t know what Linn apps are available on Surface, but on my Mac I can use Konfig app to show me the IP address of each Linn system: for the Selekt DSM I have here.
  2. What’s the IP address for your Innuos server? I have a different server (a mini-PC with Ubuntu Server), its IP address is
  3. As you see for my network, both the server and the Linn system are on the 192.168.2.xx subnet, as required by Roon.
  4. Can you go to Roon Settings>Audio on your Surface and scroll down to see if there is a section for the Linn system, but in disabled state, which you can then enable?
  5. You did not describe your network configuration. I assume there’s a router that both the Innuos and the Klimax are connected to. Can you reboot that router, and then reboot the other two devices? My Klimax DSM (at my other location) becomes inaccessible when I update my router’s firmware, for example.