No Displays in Settings available

Core Machine (Operating system/System info/Roon build number)

Synology NAS DS220plus (Roon Version 1.7 (build 710) stable)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core is installed on a SSD drive and via USB 3.0 connected with the NAS, where my music library is stored. The NAS ist connected via Ethernet with a FritzBox Router 7590.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Devices, connected via AirPlay, as well as an Apple TV and a Mac Mini with an external Monitor. (Safari 14.0.2.).

Description Of Issue

I know, for sure already may times asked in this forum, but I don’t get the Displays set-up in the Settings done. My wish is to use my mac mini and/or my Apple TV (with TV screen) to be used as Roon Displays. Under the Menu chapter “Displays”, it says “No available Displays”. When copying and pasting the Web Display Link into a new Safari Website, I see the blank (black) screen with the Roon Logo. Now, when I play music and open the volume settings, I would expect the display icon to show up, but it doesn’t. I don’t know, what I am doing wrong here. There is no firewall active and the mac mini / Apple TV and the Roon Core (on my NAS) are in the same network.

Thanks for your support,

Hi @Christian_Volkmann,

Once you’ve pasted the link in your web browser does anything show up when you click the Displays icon?



Hi @dylan: Thanks for your quick reply. and unfortunately not, I am missing the Display Icon as shown on your screenshot.I have only the following:

Bildschirmfoto 2020-12-30 um 16.36.27

and under Settings - Displays it says still: No available Displays

Can you try using Google Chrome instead of Safari? Is there any change when doing so?

sure, done, unfortunately with the same result.

I get a black window with the Roon Logo. I think the main issue is, that for what reason Roon is telling me in the settings, that there are no displays available, so nothing to select.

Thanks and best, Christian

Dear @dylan: any further ideas how to solve this issue I have with the Roon Display not showing up? Thanks.

Are you running any firewalls on the NAS? If so, make sure port 9100 is open.

Also, you can tell if a Display is seen by Roon under Settings Menu/Display. Some displays, like Chromecast, require an Enable option set in settings.

Hi. No, no Running firewalls, not on the NAS nor on the Mac Mini, and no, unter settings it says: no displays available, which is the main issue, I guess.

Hey @Christian_Volkmann, if you’re sitting on that screen, have you been playing a track? For example, I use Chrome and see that same screen until I start playback. Also, does your mac mini work fine as a display or does it do the same thing as the apple tv? Lastly, could you please copy the URL, paste it into your browser (let’s try the mini), and send me a screenshot of Settings>Displays?

Thanks for your reply.

This is the URL I copied in the browser of my mac mini:

And as you can see from the attached screenshots, it says no available displays in my settings. !And yes, I played a song (see last screenshot), but since no displays are available, the URL website remains the same (black with the Roon logo), and when clicking the volume button, no display icon showing up.

Thanks for your support,

Hey @nuwriy

I replied to your questions in my last response. Do you have any further suggestion or idea? I would really like to get this solved.

Thank you so much in advance.
Best, Christian

Hello @Christian_Volkmann, could you please try reinstalling on this device and trying from another device? Your phone should also have a display option under the volume icon. Please let me know the results and we’ll move to getting diagnostics to the QA team with that info in mind.

Dear @nuwriy,

I have done it as advised. Reinstalled completely on this mac mini, but also on my iphone and iPad. Unfortunately with no success. Display option is not showing up. Please help!

Hello @Christian_Volkmann, thanks for the update! I’m going to enable diagnostics for your account so the team can take a look. The report should upload next time your core is actuve.

Hello @nuwriy,

thanks for this Info. I am currently listening to my music, so the core is active. Please let me know, when the upload worked, and of course the result:-)


Hello @Christian_Volkmann, I got the diagnostic report and have since sent it over to the QA team for further review. Thanks for your patience! Once I have their feedback, I’ll update this thread and help you find a resolution.

Hello @Christian_Volkmann, thanks for your patience while I discussed the issue with our team. They recommended that you try a different device as the core temporarily as this might be caused by OpenV on your NAS or a similar network management software. Please let me know if you can reproduce this with another core, thanks!

Hello @nuwriy,

thanks for your reply.
I have no other device to use as Roon Core, or maybe I am misunderstanding your advice. As of now, my setup is organised as follows: I have installed the Roon Core on my Synology NAS, and I am using my Apple devices (Mac Mini, iPhone and iPad), where I have installed the Roon app, in order to use them as Remote-Controller for “Roon”. On all three apple devices I get the information in the Roon settings, that no display is available. So, for all three devices the same (negative) result.
So, which other device should I use?

Hi @Christian_Volkmann,

It is possible to use the Mac Mini as a Core machine. You can do this by going to Settings > General and then press Disconnect. From here you should have the option that says This Mac to use as your Core.

If you do this temporarily, can you try using Displays from here? Does that exhibit the same behavior?

Do you use your NAS to share a printer over the network? If yes, does disabling the printer sharing temporarily allows you to connect a display to Roon (a restart of Roon Server or the NAS might be needed to test this)?