No DSD conversion options in Audio Settings (which doesn't match the documentation)

Core Machine (Operating system/System info/Roon build number)

Windows 10 1903 Skull Canyon NUC, Roon 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired, all Ubiquiti switches, EdgeRouter 4

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Experimenting with Nativ Vita “bridge” to Meridian Explorer 2

Description Of Issue

None of my audio devices match the documentation about Audio Setup, and the various sections, so I’m not quite sure what’s going on, but the Explorer 2 isn’t DSD capable as far as I know. I have properly selected the Explorer 2 in the “Identify this device” option.

Playing back a DSD source, I’d expect it to convert to PCM. However, that’s not happening - it’s sending DSD to the DAC, which doesn’t work. And there are no settings I can find on the tab, either in the regular settings or in the Advanced expanded settings, that allow it to be selected.

I’m quite confused - I swear there used to be DSD options, but, well, not any more.


So, I think I need to turn on the DSP and manually force this to happen…which, again, is totally different than what’s in the documentation.

What I’m running into, though, is a complaint from Roon that a “file is loading slowly”…which is weird, since I’m on a Gigabit network, with a fast NUC, that isn’t remotely loaded, with network speeds only hitting ~14Mbps, from a Diskstation 2415+, with two bound Gigabit ports, also not terribly loaded…?

Example with one stream, says that it’s “loading slowly”, moves to the next (the peak), says the same thing, moves to the next:

You can see the network is perfectly capable of the burst, and then is maintaining a pretty low need (14-19Mbps or so, which is all it’s asking for).

A bit more info. If I maintain DSD - that is, I send to a PSAudio DAC - I don’t have any notifications of issues with throughput, no stuttering. And obviously the file is the same, and thus the read speed is the same as well.

I only have problems when transcoding for a non-DSD capable DAC (which the UI indicates is happening at 1.2x, and the CPU is at less than 20% use).

So - if the file is the same, and can be read, and the CPU isn’t overloaded with transcoding (even though it’s not happening at the rate I’d expect), how could there be file read performance issues?

Hello @David_Nanian,

Thanks for the detailed report. I’m going to have the QA team take a look at this for some closer analysis.

In the meantime, can you tell us if you are seeing this behavior with local content, streaming (Tidal/Qobuz) content, or both?


No issues with anything other than the DSD content (whose files are obviously much larger, and whose streamed data rate, I assume, is higher). Neither Qobuz nor Tidal offer DSD, so I have no way of checking whether DSD streamed from those providers would act differently.

One perhaps obvious question - could it actually be a problem with the device that’s being streamed to rather than the source “loading slowly”? That would make a lot more sense…

Sorry, I misread the Vita. However, my suggestion is that sometimes Roon cannot see beyond the Bridge to determine the endpoints capabilities. In those instances, and John will correct me, I think that it does determine what the Bridge can handle and use that.

The Vita has no DAC, though, so I can’t see how it could “do” DSD - it would, if anything, ‘feed’ the actual DAC, and it’s the DAC that has to be able to do DSD…

You are right, I did misread the Vita. However, I edited my original post to be more to the point I was trying to actually make.

It knew what the DAC was - it specifically said it was the Meridian Explorer 2 - but then didn’t “select” it. I had to choose it manually. But once done, I’ve given it enough information to properly “default”, no? The Explorer 2 is a known quantity.

I think I have an answer.

I (still) don’t know why the DSD conversion isn’t happening, since the device is selected and doesn’t have DSD capability. The only way I could figure out to make it work was to manually select “Max PCM Rate” in DSP options. That seems weird - it’s with both the Vita acting as a bridge and (here’s the answer part coming up shortly) a microRendu as well.

When I switched the ‘bridge’ from the Vita to a microRendu, all the ‘problems loading content’ issues went away. So the problem is not with the source (and it started saying it with local sources, with Tidal and with Qobuz), but rather that the destination (that is, the Nativ Vita) is not able to keep up with the data being sent to it (as I suggested in a previous reply, and have now properly tested and verified).

So, apart from the problem with the Nativ Vita (which one hopes they can fix), Roon really needs to improve the error messages here. I wasted a lot of time trying to determine where in my own networking, between the server and the sources, things were going wrong…and the answer, in the end, is that they weren’t…even though Roon said they were.

And now I’ve figured out the DSD thing too. :slight_smile:

As @Rugby suggests above, the issue is the bridge.

It’s not so much that Roon can’t see past the bridge: it knows the DAC (and, frankly, should make some assumptions there based on what the DAC can do). But, it does ask the bridge about the DSD capabilities, rather than relying on what it knows about the DAC. Which is weird.

The Nativ Vita doesn’t have any settings for its Roon endpoint. The microRendu, however, has a setting in its Roon “app” that allows you to specify DSD handling, and once that’s set properly, the conversion is done automatically, as expected.

1 Like

Thanks for keeping at it. I am just another user like you and was jumping in to help between breaks at work, responding from my phone. So, I apologize for not being super specific and a bit confusing. But, that is indeed what I was trying to relay with my posts.

No apology necessary: totally appreciated the help: thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.