No internet access to Roon ROCK?

Core Machine
Roon ROCK on NUV10i7FHN

**Roon Remote
Windows 10 app

Network Details
4G Broadband > 4G Netgear Modem > Unifi EdgeRouter 4 > TP Link gigabit Switch > CAT6 ethernet to Naim Atom / Sonos Arc is connected by WIFI to Unifi AP PRO access point

Music library on Synology NAS.

Audio Devices
Naim Atom
Sonos Arc

Description of Issue
I seem to have internet access from my new ROCK but as I can’t SSH onto the NUC I’m not sure how to investigate.

Symptoms:

  1. Playing internet radio to NAIM get error “Station Unavailable. Please check your internet connection”
  2. Playng from Qobuz to NAIM (or siging in once I logged myself out) I get “Network error. Please check your connection”
  3. Playing anything to Sonos Arc gets error “Roon lost control of the audio device”
  4. New tracks added to my library havent been identified (been stuck at sam estatus all day).

What does work then?
Playing music from local libary to Naim Atom

What have I tried:

  • Restarted router
  • restarted Roon ROCK
  • Changed Roon from static IP to dynamic (DHCP)
  • Changed Roon ROCK ethernet and the port it connects to the switch
  • Changed ROCK DNS from local Pihole to google
  • I can ping the roon ROCK from the Win10 pc
  • Reinstalled ROCK OS (which I think requires an internet connection??)

I dont seem to have any other network issues in my house. How should I proceed?

Thanks

Edit: I’ve stood up a ROON core in a Proxmox VM and all the issues above are not present so I think its an issue with the Roon ROCK network connectivity.

Hello @Notmy_Nine,

I am very sorry that we’ve missed your post for this long. Please, accept my sincere apologies :pleading_face:

Thank you for letting us know of the issue you’re facing, but, more than that, for already trying to troubleshoot the issue with so many steps.

I’ve looped in our technical team so they can make some meaningful suggestions based on the information you’ve shared :nerd_face:

Hi Rebeka, it did seem to be a DNS issue and changing to an external DNS provider (1.1.1.1) fixed it.

The problem with my original fixes was the DNS changes didn’t seem to be applied either when a) I saved the change or b) I restarted roon os in the dashboard or c) rebooted the device in the dashboard. In the end I needed to do a hard restart (pressing and holding the NUC power button) to get the DNS chabge to take effect.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @Notmy_Nine,

I cannot believe my ears (well, my :eyes:)! Thank you so much for sharing! I’m really glad the DNS resolved everything.

Enjoy the music!