No joy running remote on an Amazon Fire 8

Ordered an Amazon Fire 8 yesterday as they are on promotion for £49 to try the Roon remote. The app just would not connect to my Nucleus even when entering the ip address manually. Tried several times but no joy. Shame really considering the cost of the tablet but has been returned. Has anybody else tried but succeeded?.

Mine works on old 7

Yes, I’ve connected successfully to a Fire 8.

After you connect, you will find the display is unusable.

See this post -

Got mine working also. Did have to adjust the resolution as noted above. Had some issues with connection until I enabled WiFi on my NUC with ROCK. The NUC uses wired connection as well as WiFi, was the only way to get a reliable connection with my android and fire remotes.

So what is the correct DPI to set it to? The Fire HD 8?

Yeah, I don’t remember. Isn’t it stated somewhere in the doc I pointed to? Maybe @bearFNF remembers.

I never use mine, the battery life sucks.

I dont remember where i ended up either. I know it took some iterations to get it where i wanted it. I rarely use it also. 10 inch tablet or phone is what i usually use.

On the lookout now for a reasonably priced second hand iPad Air 2. Sold one on about 8 months ago as i decided the screen was a bit small for my needs. If i knew then what i now now, Hindsight eh.

I recently purchased the latest Fire HD 8-inch model, released in October 2018. It is running Android 7.1.2. There is no need to resort to the DPI fix through a computer connection to get Roon running in landscape mode. The same thing can be achieved in the tablet settings.

Make sure developer mode is activated (Google how to do this). Then:


Device options

Developer options

Smallest width (under “drawing”)

While holding the tablet in portrait mode change the width settings. This will change the DPI. The changes can be confirmed with one of the many Android programs that verify your screen’s DPI.

The following “smallest width” settings all worked for me. Please note that after you enter them, the tablet may auto-adjust them slightly.

670 (tablet stays at 670) = DPI 191

650 (tablet adjusts it to 653) = DPI 196

648 (tablet adjusts to 649) = DPI 191

Roon automatically opens in landscape mode with any of these settings. I have no idea whether this will work on earlier versions of the Fire HD 8-inch tablet.

1 Like

Amazon Fire 8 HDs are now £44.99 so I’ve picked one up and hope I can get it working when home later using this advice

You no longer have to take the steps above to ensure it works in landscape mode. Subsequent Roon updates have made this unnecessary. You can just download it from the Amazon App Store and it will work fine.

I will go back and undo everything I’ve just done then :joy:

Actually, you don’t have to do that if you like the way it looks at the moment. I still have one of my two Fire Tablets with the altered settings and everything works fine. But if you didn’t originally install the Amazon store version of Roon it’s better to go with that or you’ll have trouble with auto updates.

I have two HD Fire 8 and on HD10.

All work well with the Amazon App store ROON download.

No adjustments needed.

A year ago, before Roon made a version available on the Amazon store, adjustments were required for the smaller Fire tablets. No more.

Have an Axon Mini 7 sitting in a draw not being used so decided to set it up and use it as a remote as an experiment. Used up several hours trying to connect to the Nucleus core but Android just would not play ball. Sometimes would connect reluctantly other times not at all!. Axon back in it’s resting place in the draw, Shame.