No local audio device found in Roon client on Windows 10 pro 20H2

I’ve a problem with finding my local sound card (Pinell DAC mini usb device) in the audio section of roon. It used to work in the past without any problems. Can’t remember exactly when it stopped working, either windows upgrade or roon software upgrade. Can play to other devices without problems, Squeezebox, AirPlay, Chromecast, etc.

The roon core server is running on a Ubuntu server.

All software of roon core and root client is at the most recent version.

What I’ve tried so far.

  • delete C:\Users<user>\AppData\Local\Roon and RAATServer (database, etc)
  • uninstall and reinstall Roon client on Windows 10 server and remove all configs from C:\Users<user>\AppData\Local
  • Disable firewall on Windows 10. Checked that telnet worked from the roon server to my Windows workstation.
  • Disable all other internal soundcards
  • Was so frustrated that I reinstalled my Windows 10 workstation. Result was the same, no local audio device found.
  • reboot roon core server
  • exclude roon and raatserver in the antivirus and firewall

I can’t really get no local sound. This is so frustrating that I use Audirvana when I need sound on my local card.

I really need help to get roon working again on Windows 10, since it’s really the best system around. Please help me, I’m very desperate now… :slight_smile:

Sorry for the trouble here, @Tommy_Olsen!

Can you share a screenshot of Settings > Audio?

Please also use the directions found here and send us over a set of logs using a shared Dropbox link. Thanks!

Sure have made a information package with everything you ask for. Logs+screenshot

Download link:

Hi @Tommy_Olsen,

It sounds like just the Windows 10 is impacted in this case and the rest of the zones tied to the Core work as expected, is that correct?

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Ok, thanks for all the tips and tricks. I got it working now. I use nod32’s firewall. Made exception for everything roon and raat, database, firewall exception. My computer is domain joined, so I made it discoverable, etc. I use a pretty big netmask, because my house is crowded with all sort of network gadgets, virtual machines, etc.

Have to tighten the security bit by bit until I find what did the trick? Can you explain in details how the roonserver detects my Windows 10 roon client, ports and protocols. Then I can tighten what’s not needed.

Hi @Tommy_Olsen,

Thanks for letting us know that setting up the exceptions helped here!

Roon uses quite a few ports, including ones that are randomly generated at startup, so in this case we suggest having an “Application Level” firewall exception in place. Hope this helps and Happy New Year!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.