No Mojo on Macbook (as remote) connected to Windows Roon server [Solved: Firewall]

Right now, I feel kind of stupid. I’m new to Roon. Yesterday I installed a Roon server on a stationary Windows computer.

After that I installed Roon on a MacBook Pro and configured it as a remote. Now I have all music stored on the windows computer which is connected to to an USB IFI DAC.

But I want to listen in the bedroom, so I put the Macbook on the bed and connect a Chord Mojo, but it does not show as a choice to “Enable” - I have also tested with a Dragonfly Red. None of them is turning up as a device in Roon: Settings / Audio on the Macbook pro.

In the screenshot, I have the Dragonfly connected and chosen in the Macbook system preferences.

I am not certain that Roon is supposed to work as I want, but I think so.

Is it so simple that a Macbook with USB DAC set up as a remote cannot be an output “device”. It can only control the Core server installation?

A DAC connected to a remote should show up in the audio settings. Also your regular Mac system output should be available. Could you check if a firewall is involved on your windows core system? Try to turn it off temporarily and check if it changes anything.

When I restart the Windows Core server, the Macbook cannot connect. An iPhone and iPad connects without problem. It must be something related to the Macbook. But there is not something like a firewall in OS X, or is it? I will have to check that up :slight_smile:

Thank you Christopher for getting me on my way. I have a new Macbook and the firewall was blocking everything. I had a lot of Macs before, but never had to fiddle with the firewall. Now I can see the Mojo! :slight_smile:

1 Like

Yes, firewall on the Mac should be disabled as well. I was assuming the windows firewall as it is enabled by default (in contrast to the Mac one…) :slight_smile:


If you’d like to keep your Mac firewall enabled you can add additional rules for Roon:

  • Open your Mac’s System Preferences. Open “Security & Privacy” -> Firewall
    Click the lock at the bottom of the window and unlock the settings by entering you user password.

  • Click “Firewall Options…”

  • Keep the window open and switch to the Finder.

  • Locate Roon in your Applications folder. Right-Click on the Icon and select “Show Package Contents”.

  • Navigate to Contents -> Resources and drag Roon and RAATServer into the Firewall
    Drag Roon and RAATServer into the list of allowed or blocked Applications of the firewall settings:

  • Click OK and you are done.
1 Like

Thank you Christopher, this helps a lot!