No network connection to Music Folder on Naim Uniti Star

Core Machine (Operating system/System info/Roon build number)

Windows 10 Home 1903 Build 18362.418 with Roon 1.6 (Build 416) on a Razer Blade Pro 322 GB Ram

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Zyxel VMG8825-B50B https://www.infostrada.it/fileadmin/Materiale/guidemodem/Manuale_HL_HUB.pdf

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim Uniti Star connected via WiFi

Description Of Issue
My Music is stored on a SD card on the Naim Uniti Star. Path \UNITISTAR424624\Music\MQ
I am not able to connect to the device via Roon. (Connection via Windows Media Player works pretty well)

Logfiles:

Hi @Emil_Worndle,

  • Are you able to access this path when using Windows Explorer?
  • Does connecting to the Uniti via IP address in Roon work as expected?
  • Have you tried both types of SMB notations mentioned in our Add Folders By Path Guide? (\\UNITISTAR424624\Music\ and smb://UNITISTAR424624/Music)?
  1. I am not able to access the path by Windows Explorer
  2. Too complicated for me (need to have it done by DHCP and/or UPNP)
  3. If i want to add any of the paths i get the message: invalid path

You cant use local storage on the Star as it is not shared over the network only via the Stars UPnP server. Roon does not support UPnP. You need to have music on your core machine or a valid network share from a computer or a Nas.

I am a network analphabet. I can ony say that it worked before.

Apologies I forgot the the Star works like the Uniti Core as it does rip, I forgot that as I have an Atom and can’t share any attached drives at all. Others have had issues with Naim Unity cores adding them to Roon. Your running your Roon core on Windows so first you need to enable smb1 sharing as this was disabled sometime ago in a windows update.

Also ensure Roon has full access through your Windows firewall there will be two entries you need to let through.

When done try to connect to the stars music store via windows explores as above. If that does not work replace the name with the cores actual ipaddress. You can find that in the Naim app.

If you still can’t connect to it via explorer then I would contact Naim as you should be able to and if windows can’t see the storage neither can Roon. Window media player is seeing the Stars UPnP server not the network share so that’s why you can see it in there.

Hi @Emil_Worndle,

I would check to make sure that the share shows up in Windows Explorer properly first.

I would locate the IP address of the Star and try typing this in to Windows Explorer to see if it works. Only after you have confirmed that this works outside of Roon properly should you try to add it into Roon.

If the IP Address of the Uniti Start is set to DHCP, you may want to add a Reserved IP for it in your router’s configuration settings.

Eventually, after a restart of the modem/router the path to the folder on the Naim Uniti Star started to work again. I installed as well the SMB version 1 protokoll.
Nevertheless the Uniti Star does not show up in the Windows Explorer (automatically).
Only if i type in the path \UNITISTAR424624\Music\MQ, the device, folder and files now appear in the Windows Explorer.
So, in a way the main issue seems to be resolved but the system still doesn’t work as smooth as before, when the device and folder appeared automatically.
Any hints to improve the situation are well appreciated.

As a network analphabet I think not to be able to add a Reserved IP for the Naim in the router’s configuration settings.

It’s possible to access the Star music folders via a browser by entering its IP address. This is how you add music to it (other than CDs ripped on the Star). It certainly works for USB drives, and as far as I’m aware, SD cards are treated the same, although it might be worth confirming this with Naim if there’s any problem. Whether or not Roon is allowed access to this music folder too, I couldn’t say. It’s not possible on the other Naim streamers, but they are a little different to the Star.

You may need to map the drive to allow it to be found. As a Mac user, I’m not the best person to help you with this, though!
If you want to reserve an IP address for the Star, you should do it on your router. This is usually straightforward, although exactly how it’s done will depend on the model of router you have.

Hi @Emil_Worndle,

Glad to hear that the path is working after a router reboot!

The instructions for this are located on page 38 of the manual you posted:

This would just be a change to ensure that even if connecting via the hostname (\\UNITISTAR424624\) is not accessible, then the IP address will not change and still remain accessible.