No output from Hifiberry DAC2 HD with RopieeeXL 2022.04

Hi there, and thanks for the great software. I was adding some new Pis today (with Amp2 HATs) and decided to upgrade to your rewrite of RoPieeXL. Several of the Pis are working as before (4 with Amp2s, 1 via USB to a Benchmark DAC). My two DAC2 HDs show up as endpoints in Roon, but there is no output. Using Device Volume (which is what I used on the old RoPieeeXL version), the slider pops back to 0. Using DSP volume, the slider will remain wherever it’s set, but I’m not getting any output. I’m sure this is user error, but just checking in in case you’ve seen this happen elsewhere. Logs submitted with code 8e2777df03bee059

Thanks!

Steve

Hi,

There are some problems with the Hifiberry DAC2HD in combination with the 5.15 kernel.
Those are still not resolved by Hifiberry, but we’re using the work-around. Which should work.

I can see that the device is properly initialised, so not sure what’s going on. Have you tried with all XL services disabled? To make sure nothing interferes?

Thanks

Hi, @spockfish. Yes–have tried with all XL services disabled (and the 180 Ropieee build); same issue.

Same here. I’m on a RoPieee 2022.04 (no XL) with a HiFiBerry DAC2 HD. No way to get the Roon volume slider stay beyond 0. You move it and it slides back to zero. No way to get sound out of the RCA.

I’m relatively new to (audio) RPi. I bought my DAC2 HD on Amazon and I’m tempted to send it back and buy a less fancy HAT DAC, may be one not so easily broken by kernel upgrades.

Is there a way regular users may implement the workaround cited in your previews message?

Logs submitted with code199ef136578dd211

Thanks

Mauro

@Mauro_Filippini I think @spockfish was saying that the workaround had already been implemented in 2022.04, though it apparently does not address the issue we’re having.

@spockfish In the meantime, is there a way to downgrade to your previous version with the old kernel? I don’t see an archive of old images on the ropieee.org site.

Thanks!

The work around is implemented; no idea why it isn’t working tbh.

And nope, the previous version is not available anymore.
Here’s the image of the previous version: https://image.ropieee.io/ropieee_ose_pi4-2022.3.0-stable.20220310.126.bin.xz

Just to be clear: no support and I can’t guarantee how long it will stay available.

Oh, and don’t update :wink:

Thanks

Thanks, @spockfish.

Confirmed that I get output from this version (still have an issue from the old days, where the mute function in the Roon app doesn’t work for the DAC2 HD endpoints, but that’s obviously pretty minor).

Understood on no support and not updating!

Thanks again,

Steve

1 Like

Thanks @spockfish and @Steve_Putman

of course, no support and no complaints about 2022.03.

I’ll give it a try. Or I’ll wait 2022.0X to be released. At the moment, the RPi4 + DAC2HD is a side project for getting Roon stream also in the kitchen (on Como Audio Solo + Ambiente). I reckon the DAC2HD is overkill for that purpose, and regular DAC+ could be more than enough.

BTW. The same HW (RPi4B+DAC2HD) works “about” fine under HiFiBerry OS (apparently no volume slider issue through the Roon interface). Besides, under HiFiBerry OS, the RPi box is recognized under the group of “Roon Ready” equipment on my network. Vice versa, under RoPieeee, the DAC is just labeled as “Roon” (not “Roon Ready”), and it’s listed separately. Don’t know if it’s relevant info (for the volume issue) or just the expected behavior.

Thank you

@Steve_Putman and/or @Mauro_Filippini,

Are you willing to participate in a beta test?
Although it is confirmed this is a Hifiberry issue, I’m still trying to figure out if there’s a proper fix.

Thanks

1 Like

Sure. Need to keep it working for a party tomorrow, but after that I’m good to go.

Great! Don’t want to interfere with the party :wink:
I’ll share a beta tomorrow, curious on how it behaves.

Regards,
Harry

Same for me. At the moment the RPi box is sitting idle on a shelf (powered and attached to the network) waiting to be resurrected …

Regards

Mauro

@Steve_Putman and @Mauro_Filippini ,

There’s a beta build available, see the other thread.
Let me know how it goes!

Thanks

@spockfish Updated to the beta (2022.05, kernel 5.15.33).

Unfortunately, on the Ropieee powered DAC2HD the volume slider is still going back to zero. I slide it up 100% and when I raise my finger from the mouse, after a fraction of a second, it goes back to zero. I’m controlling Roon from the Mac, build 931.

The other devices are working fine:

I don’t know if it has something to do with the latest version of the RPi board (I’ve got a RPi 4B rev. 1.5 board).

Logs submitted with code a7cdc2f7311075ea.

Let’s see what @Steve_Putman gets out of his board(s).

Thanks

Mauro

That’s weird.

The logs show clearly that Roon is capable of setting the volume.

So @Mauro_Filippini

If you go back to the 2022.03 version that it works right? Without changing anything?

Is there a possibility that you send me feedback with the 2022.03 release?

Same issue with 2022.05. Log id: 1bee7d193d2a9e24

@spockfish RPI4B1.5+DAC2HD works fine with 2022.03. Log id: 004c587445ccc668.

If it may help. After downgrading to 2022.03, Roon sees the RPi box as muted (at volume=46/100) at start-up. However, the mute function doesn’t actually work (as @Steve_Putman already pointed out):

Here you may have a look to what’s happening under 2022.05 (I didn’t record any audio on screen capture, as I was just getting pops and clicks by volume sliding):

RPi4B15_DAC2HD_RoPieee_2022-05

On 2022.03 it works as intended:

RPi4B15_DAC2HD_RoPieee_2022-03

Thanks

Regards

Mauro

Very valuable @Mauro_Filippini !

The ‘mute’ thing slipped my attention the first time.

Looking into this. I think I need to order one myself.

Longshot @Mauro_Filippini ,

But I’ve pushed out another beta that reverses one of the audio component updates.
Again, longshot, but let’s rule out a few things.

Thanks!