No Overview or Discover Pages

Really enjoying the software so far.

When I started Roon Core this morning, the Overview and Discover pages remained blank with just the Roon logo in the middle of the page. It has stayed this way all day, even after program restarts and computer reboots. The Remote computer has the same behaviour.

Disregard. Just like taking your car to the mechanic to check out that annoying little sound, as soon as I posted, the pages came back, like magic.

Anyway, I’m really, really enjoying using this software. Cheers.

1 Like

Nope… it’s a bug. I see this, frequently. I am running RoonServer on a Mac Mini and using a MacBook Retina as a remote. I always start at the Overview, because I can see my most recent albums.

The Roon logo will appear for a bit, then it’s just a blank screen. I’ve also seen this with an iPad as a remote.

If I navigate to the queue (even if empty) and then go back (clicking on the hamburger menu icon with the music note on it), it will return to the overview, the Roon animated logo will appear and the Overview page will refresh normally.

I have the same problem. The roon-logo just hangs and nothing else happens…

Can you give us some details about your system and what you’ve tried so far? Have you restarted your Core?

Hi Mike,

I’ve restarted the core to no avail. I even went as far as disconnecting my tidal account, but this led to more trouble. I have now gotten Tidal back (although I cannot browse the Tidal categories. “new, recommended, rising, etc”), but after removing all storage Roon will not add back the local files.

My setup is as follows:
Win 7
Latest Roon build 102 64 bit
Intel® Core i3-3220 Processor
Socket-LGA1155, Dual Core, 3.3Ghz
Kingston ValueR. DDR3 1333MHz 8GB, CL9Kit w/2x ValueRAM 4GB DDR3
Streacom FC5 OD SortFanless, mATX, mITX,
ASUS P8H77-M, Socket-1155
Corsair SSD Force Series 3, 60GB
Hitach 2gb internal hdd

So to sum up:

  • Overview/Discover/TIDAL isn’t showing
  • Importing of locl files (on second internal hdd) is stuck as described in other threads. 486 tracks, 67 added, 0 identified. Btw, there are thousands of tracks in the added folder, not just 486.


When searching TIDAL doesn’t return any results (tracsk, albums artists etc.).

My tidal albums are still available in the albums display, and play correctly.

@Andersen, It feels to me like a network problem – Roon can’t connect TIDAL, servers which are responsible for identification etc. Can you describe your network topology ?

It’s not a network problem. In lack of any answers i did a clean install and it is working fine now. Bummer about the import dates though.

It may not be caused by the same issue, but yesterday I was seeing similar problems:

  • Overview/Discover/Tidal pages were blank (just the Roon logo showing) on all except one of my Roon remotes.
  • The Album list was showing on all machines, but some albums refused to load (got the Roon logo and album loading message showing forever).

It turned out my SSD was corrupted. Windows fixed it, and I reinstalled Roonserver on it again. Everything seems OK now…