No pictures appear [resolved: firewall]


after the update to 882 all pictures are missing.
Local and also Tidal’s.

I have already tried:
clearing the cache
network check

Unfortunately no success.

Thanks for your help.

Hey @jules, sorry for the trouble here. I’ve got a few questions:

  • Do any images load?
  • Are you able to play any music from TIDAL?
  • Does rebooting your router help at all?
  • What’s your upload/download speed?

Let me know!

Hi @kevin

  • none of the pictures load
  • yes i can listen to music via tidal, including local files
  • no it doesn’t help
  • I have a 1 Gbps up / down connection


In case relevant, I have found album art on my iPad to be intermittently very laggy since 880 (issue persists in 882). My core is wired to a standard Netgear switch. Here is an example, I had plenty of time to take this screen grab with missing Tidal album art, which eventually appeared. Can’t recall this happening prior to 880.

@jules Do you have any firewalls or custom networking stuff going on? Any restrictions on network ports? If you could describe your network in as much detail as possible, it would be a huge help!

For me it doesn’t show any pictures. Not even from my local albums.

Yes, I have. Opnsense.
I deactivated all the rules for test purposes. No success.
In addition, I don’t see any indications in the firewall’s log.
Today the update to 884 made, still the same.
Could it be that you changed something on the network settings during the update? Because before version 882 everything worked.

Hi do you use Logitech G Hub by any chance? Uninstall that :slight_smile: If not, I don’t know the answer.

Nope, I don’t use Logitech G Hub.

Is your Core up and running? we are attempting to get logs from it, but failing to do so.

What’s your DNS like, we are seeing a lot of people failing DNS lookups … try and restart the Core?

How did you retry? restarting both the core and the remote would have been a proper test.

The core is always running.
Opnsense queries directly the root servers.
I am happy to send the logs if desired.
I restarted the core and the remote with every test.

found the problem …
I had to add more ports to the ufw in linux.

enabled are now:
9100: 9200

Roon uses dynamic port #s and discovery between processes. Firewalls blocking ports on the lan will cause breakage.

Why did this not catch it?

In addition to the open rule for the firewall, I had to add ports 9330 + 9332 to the ufw in linux.
Before the update my settings worked flawlessly.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.