No Playback and Tracks Skipping through Rasberry Pi / Digione endpoint

Core Machine (Operating system/System info/Roon build number)

Roon Core on Synology 218+ NAS, Roon version 1.6 (build 416) 64bit
Roon Bridge on Rasberry Pi3/Allo Digione Sound Card [Dietpi] Version 1.0 (build 169)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi Mesh on Rasberry Pi3 built in Wi-Fi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Hegel H90 Integrated Amplifier through Digione Digital Coaxial

Description Of Issue

My Roon playback suddenly stopped working and skips tracks through Digione after re-configuring to a Static IP. My Roon setup through the Digione was playing perfectly after initial installation. After setting a static IP for the Digione, I now play a track and the time does not run and the tracks automatically skip to the next after about 10 seconds of inactivity. Roon recognizes my Digione correctly, with the correct IP addresses and settings. When I play a track, Roon acts as if it’s trying to play, I even get the correct signal path. However the time bar for the track does not move, stays on 0 minutes played, and after about 10 seconds the track automatically skips to the next one until the queue is finished and stops playing completely. This also happens regardless of the music source, NAS, Tidal, Qobuz, all have the same issues.

This only happens on the RPI3/Digione, I have another Roon bridge (Cambridge Audio CXNv2) and Roon works fine on this endpoint which was also set to a Static IP the similar to the Digione.

I have tried all of the following with no success:
Restarted Roon Core
Deleted RAATServer folder
Set RPI3 back to DHCP handling
Restarted all network devices
Disabled Airplay Sharepoint
Disabled Ethernet port

I’d appreciate any help, I’m stuck at this point on what could possibly be a solution other than re-installing everything.

Thank you,

I’d make sure it is the IP change and not a coincidence by rolling back the change and see if you still have the problem.

I did set it back to DHCP and rebooted everything but the problem continued.

How is the digione connected, wireless or cable?

Wireless, I don’t have ethernet in that area of the house where the system is.

Might be worth moving it temporarily to where you do and try it wired.

It works through ethernet I’ve already checked that. It’s seems like a problem with the wi-fi communication within Digione or dietpi that’s getting corrupted for some reason.

Try reinstalling the Pi operating system, if you haven’t already, and see if that triggers something on the Pi.

Hi @Richel_Hernandez,

The other endpoints you’re able to play to — Are they also on WiFi?

Are you able to play to the device as an endpoint outside of Roon without issue?

I made another new dietpi install on a separate SD card, no change, same issues.

@dylan yes I have a cambridge audio cxnv2 which uses internal chromecast also on Wifi and I can play it through Roon with no issues.

As soon as I connect an ethernet cable it works fine. I’ve tried disabling eth0 in case of a conflict but nothing. And as mentioned it was working fine on wifi before.

I just tried adding in a wireless access point and connected the RPI3 to the ethernet port of the new access point and it did not work, same issues.

So the only way it works now is if I connect the RPI3 via ethernet directly into the router.

Hi @Richel_Hernandez,

If you use this device to play content to outside of Roon using the WiFi do you experience any similar issues?

Problem solved, it turns out the 2nd power cable that powers the Digione board was damaged somehow. I was using a different power cord when plugging it in via ethernet, I just happen to use a different cord one time and it worked. As I retraced my steps I found the power cable was bad so the Digione board was not turning on. What’s odd is in the Dietpi menu I could still choose the Digione board to output audio.

Thanks for putting up with the nonsense.

Was it a Digione or a Digione Signature?

It’s a Signature

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.