No Recognition of Airplay

Roon Core Machine

Laptop running Windows 10d

Networking Gear & Setup Details

Connected Audio Devices


Number of Tracks in Library

Description of Issue

Roon will not recognise Airplay on network player for 2nd system.
It recognises the Bryston player on main system (after several times rebooting the player and closing/re-opening the Roon software).

Firmware up to date and network is the same as that which the laptop running Roon is connected to.

Hi Fabian,

Welcome to the community.

Is it the SMSL you’re trying to Airplay to and can you post a screenshot of the audio section in Roon? Go to settings and it’s the “Audio” tab.

Thanks for your response RBO. Please see attached.

Cheers Fabian.

Is it the SMSL you want to Airplay to?

Also have have a read here

Hey @Fabian_Beckett,

As @RBO mentioned, welcome to the community! We’re excited to have you here.

I wanted to check in on this issue and see if you’re still running into airplay issues? While you mentioned the firmware is up to date, I wanted to check if you have the most up-to-date drivers for this model as well?

Also, it looks like there’s an option within the network settings to enable airplay, can you confirm that you’ve done this as well?

@RBO is also steering you in the right direction with digging into the roon help article on setting up airplay.

We’ll be monitoring this thread for your reply :+1:

1 Like

Hi Ben/RBO,

Thanks for the messages. Yes, it is the SMSL that I want to Airplay to. I read the link before posting here, but have had a re-read to check that I’m not missing anything.

The firmware is up to date. I have installed the drivers (I hadn’t realised these would be needed for airplay), but still no luck. I have tried factory reset and reinstalling the firmware, restarting everything. Airplay is enabled on the SMSL. It’s on the same network, both with good signal. No airplay option shows on Roon at any stage during the various combinations tried, but it is now registering the DAC when connected to USB. It is a start, but I really wanted to be cable free. Do you have any other suggestions?


Hey @Fabian_Beckett,

After checking on your account, it looks like you were able to connect the SMSL 2 days ago. I wanted to see if this is correct and if you were able to sort out your airplay issue?

If not, are you able to test setting up airplay on another compatible device with the SMSL? If you haven’t yet, please give your core and devices a hard reboot as well.


Apologies for the delay. I was only able to connect Room to SMSL via USB, not Airplay. I have no other devices which I can attempt to use airplay on. I have hard rebooted everything previously with no joy. I’m missing out on a lot of the functionality that I paid for because I’m limited to just my main system.

Hey @Fabian_Beckett,

Thanks for letting me know. After taking a look into the manual for the SMSL (you can take a look at it here : page 17) it only mentions airplay in regards to iOS devices.

Because your core is currently operating on a windows OS, I wanted to check in to see if you’ve properly setup airplay compatibility on your core machine? Here is a helpful article that breaks this down further

I’ll be on standby for your reply :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.