No sound after software update on nuc roon server (ref#72YP56)

What best describes your playback issue?

· Playback starts, but I don't hear any music

Is there a specific error message you see? If so, please select from the following options:

· Other

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I don't have a System Output available, but I'd like to keep troubleshooting

Please try fully rebooting your network equipment

· No, I'm still having trouble

An issue with playback on System Output and another zone often indicates a network security problem. *Check your firewall(s)* to ensure that *Roon*, *RoonServer *and *RAATServer* are allowed to properly communicate

· I'm still having problems / This isn't relevant to me

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· does not apply

Describe the issue

I have a nuc roon server that I built. I have two set-ups, both running off streamers using volumio...before I list all my gear etc....I just want to state the basic problem. Everything was working perfectly...until....I installed the latest software updates. I think I may be having some kind of volume issue in both of my zones. My dacs show that they are getting the signal from the streamers. When I press play in the roon interface it plays fine...like normal. I am just not getting any sound now in either one of my systems. I control my volume manually with my devices. I am thinking for some reason with this update it changed something. Not sure what? I have system updated before...and not experienced this problem. I am 70 years old. Set this all up on my own...but I forget stuff....LOL! I poked around but cannot seem to find anything. Any suggestion would be greatly appreciated. (I did reboot my modem, network switch...the roon server several times....to no avail). Thanks.

Describe your network setup

I have a Netgear Nighthawk CM 1200 Modem and an LHY SW8 Network Switch. I am hardwired with my streamers.

I think knowing what devices you are streaming to (and which protocol they are using) would be helpful :slight_smile:

I have a Volumio Rivo (Roon Endpoint), streaming to a Denafrips Pontus II via USB in my main system.
In my office system I have a Mercury Streamer (1) streaming to a Violectric V800 DAC via balanced and/or optical.
I can see that the Dac is getting the stream…and since it is both set-ups have no sound, and it happened after the Rock software update on my NUC…I am tending to think that it may be something obvious that I am overlooking in the Roon Software, some setting that changed with the update…but that is just a guess. I am in the correct zone in each location, and everything looks normal…and plays normal…just no audio. Thanks for asking.

@PixelPopper & @Jabbalabba - the best course of action is always to open your own Support request and describe your setup in detail if you want help.

You may have a similar symptom, but not necessarily the same cause as the original poster - your system setup may be different, that’s why the general rule is to always first open your own request. Let the Support team merge threads if they find common causes.

6 posts were split to a new topic: Playback starts, but I don’t hear any music

Hi…Question…did this start occurring AFTER you installed the latest software updates?

This info may matter… In my main set up, I run the Roon interface on my iPad…in my office I am running roon on my iMac Browser but this in not my roon core. (As stated earlier I have built a Roon Server on an Intel NUC…running ROCK). I believe that it was the lastest ROCK update that caused this problem…

And based on my two separate set-ups… my suspicions have me leaning toward something that was reset or changed on my Roon Core interface/software that has changed something fundamental in the software, causing both of my set-ups to have no volume.

I can see that the stream is reaching the DAC in both systems. Both systems play other sources just fine…so I am not having a system issue in my office or my living room. I do not think it is any kind of network issue because the Roon stream appears to be reaching my DACs in two separate systems… and other than this situation my network is A-OK no issues and I have changed nothing in my network.

For me… the “tell” here is the Roon Software Update… but I am no expert in these pursuits! LOL! Because I am no expert…I am suspecting that whatever changed my be something simple and obvious, even… but I am not astute enough to catch what it is… but I am betting that it is something basic.

Edit: Can I add a photo here somewhere?

I took a screenshot in my audio section of my software showing my Streamer info. I am wonder if this might have something to do with “airplay”?

I am lost with that stuff… AirPlay, Chromecast etc… I do not have a grasp of what is going on with those entities… Oh… I am human… LOL!

Thank you!

1 Like

Done that, thanks Geoff, it seems like “Airplay 1” is broken again, even with compatibility enabled none of my devices are working since the update…:roll_eyes:

Thanks for the post. So we just have to wait for a software fix?

I’m afraid that’s likely to be the case & support don’t appear to work weekends so it could take a while unless someone discovers a workaround…

Thanks soooo much for your input.
:+1:t3::+1:t3::+1:t3::slightly_smiling_face:

Hi @BobB,

Please try restarting your RoonServer machine twice in a row.

We’ve activated diagnostics for your account and noticed that content from streaming services and Roon’s servers is failing to download due to network reachability changes. Put simply, this ROCK is having a tough time reaching the internet reliably. Do you have the device hardwired directly to the router? Try a different port if it’s routed through the switch.

We’ll keep an eye out for your response.

Hi Connor…
Thanks for getting back to me.
I will tell ya…I was not having ANY network issues. Everything is hardwired…I have tons of bandwidth and all that is REALLY GOOD…I reworked all of that a while back and upped my service.
I have things working now…It had something to do with the Audio settings in the Roon Interface for both of my streamers:
Roon Menu to Settings to Audio to each of my devices (Mercury Streamer & Volumio Rivo Streamer).
I had to open device set-up for each device (photo attached) click on the gear menu to Show Advanced.
Both of my Devices had Compatibility Mode on “NO”. I had to switch them both to “YES”. and make sure that I was on Fixed Volume. Then all was good.
I am guessing that the settings changed with the software updates. What I find to be weird is that even when it was on “NO” both of my streamers were registering the signal, but there was no sound??? I do not know what any of these switches mean or what they do…Any insights would be helpful to my understanding.
Thanks…Bob

Exactly, it was added with AirPlay 2 as a fallback for older devices that don’t work with the AP 2 protocol version.

@Connor it would be really good if the compatibility mode could be added to the docs e.g. at https://help.roonlabs.com/portal/en/kb/articles/faq-i-m-having-problems-setting-up-airplay and the release notes for the new version where this info was omitted (although ithe option was added during EA specifically for devices that didn’t work otherwise and therefore is quite important)

2 Likes

OK…I want to understand more… hope that I am not a nuisance.

  1. So… was the “airplay” switch just added in the update?

  2. Secondly… Even tho I built and installed my NUC server (with much patience and fortitude :dizzy_face:), I don’t understand a lot of what is going on. (70 yrs. old)… So I have both of my set-ups “hardwired” to the streamers, with the ethernet cables. Everything is hardwired. My main system I run with my iPad… but it is not used for volume (I do that manually with my system), I just to use Roon to stream Qobuz and/or play files off the server… Same thing in my office set-up, but I use Roon in a browser on my iMac there to play music, but I adjust the volume manually that system as well.

Airplay is an Apple WiFi protocol, right? How does that fit in here. I am trying to wrap my head around how the whole system functions. I don’t need a very technical explanation…something more of how you might explain it to a child perhaps! :grinning:

Thanks.
Bob

The “compatibility mode” switch was added for AirPlay devices because the update added AirPlay 2 and some (typically older) devices refused to work with AirPlay 2 during testing, so I suppose the switch may revert to the old AirPlay 1 method for these devices.

Very good :slight_smile:

Not quite, it’s Apple’s network music streaming protocol. Despite the name, it works over Ethernet as well. I suppose the idea of the name is that it works transparently like through air, but it uses whatever network connection the device has, be it Ethernet or wifi.

  1. OK…so the switch was added but just in the wrong position for me! LOL! Makes sense!
  2. THANK you so much to explain this. The name “Air Play” is not reassuring to someone who wants to stream over their hardwires!!! LOL! I REALLY appreciate you explaining that. THANK YOU!!!
1 Like

Hi @BobB,

We’re re-visiting these reports to illuminate development’s effort to improve Airplay 2 performance in Roon.

Are you still encountering these issues after toggling on Compatibility mode in Device Setup?