No sound after updating to 1.2[solved]

I have a CAT music server that runs Windows 8.1. Roon Server is hosted on the music server and i have the Roon app running on an iMac and Roon Remote running on an iPad. Roon tells me that i have the lastest version (1.2, build 123) installed in both the CAT and the iMac. It is a simple dedicated audio system with only the single playback “zone”. The Audio Settings in Roon all changed and i now have no sound. I’ve tried fiddling with the settins as best as i could, but to no avail. What do i do?? Thanks!

Good timing! Build 128 just went live. :wink:

Give it a shot, and if you’re still having issues, let us know a little more about your setup and we’ll take a look.


new build auto loaded and installed. Still no sound. Connections to this Mac and Connections to Core all have tabs showing Enable. I tried enabling system output on connection to the core and tried both
“use wasapi” mixer (whatever that is) and “fixed volume”, which i thought was the correct setting. In either case, it comes up as “device not found” and no sound coming thru the system.

Hey @harry_masoni,

Would you mind to give us more info about your setup - use this FAQ as a guide ?

Based on the manufacturer’s website CAT is a streamer/ripper/nas and it requires a DAC to be connected to it. What device is connected to your music server?

Also, If you want to playback music with a Sound card/DAC connected to your iMac - you need to enable zone which are under ‘Connected to this Mac’ section.


The CAT usb output feeds the Stahltek ABC (which is a usb/i2S converter) which feeds a Stahltek Opus Prime DAC which feeds a Pathos Inpol2 Integrated Amp (Volume Control).

The iMac is just a “client” which hosts the Roon app as well as a Microsoft Remote Desktop app to control the CAT. The iMac should not be in the music chain at all. So what zone is to be enabled under “Connected to the Mac”?? I have two choices that show up ; Built-in Output (Apple Core Audio) which can not be correct, or System Output. If i “Enable” System Output i have the cloice of Use CoreAudio Mixer(don’t know what this is), DSP Volume (which i know i don’t want), and Fixed Volume (which i think is the correct setting?? Under “Playback”, both the max sample rate and the bit rate are Disabled, although i think i could set those at 192 and 24 respectively, because that is the capability of the DAC.

Windows drivers from Stahltek were installed in the CAT and the system was working flawlessly on 1.1.

I appreciate your help. Let me know if more information is needed!!

Hey @harry_masoni – sorry for the trouble here. Let me make sure I understand the setup.

So, your Core is running on the CAT server, which runs Windows 8.1. The output you’re configuring is the ABC, as described here:[quote=“harry_masoni, post:5, topic:9942”]
The CAT usb output feeds the Stahltek ABC (which is a usb/i2S converter) which feeds a Stahltek Opus Prime DAC which feeds a Pathos Inpol2 Integrated Amp (Volume Control).

The iMac is just a remote for Roon, and is used for accessing Windows on the CAT remotely.

So, the output in this case will be in the Audio tab of Settings, under the section Connected To Core, like this:

Once you find the ABC in that section, you’ll want to configure it according to the DAC setup instructions here. You may want to tune the resync delay if you’re not getting smooth transitions between different sample rates, and you’ll also want to set the max rate to match the capabilities of your system.

Let me know how that goes @harry_masoni and we can take another look if you’re still having a problem here.


Thanks Mike, but several problems here. … .

First off, i don’t know what Core is. I have RoonServer running on the CAT. There is NO direct user interface with RoonServer on the CAT. My understanding is that the “Core” is the main Roon application and i thought that is installed on my iMac as a Roon “client”. I’m very confused with the architecture and terminology. It was set up for me by a very knowledable Roon (and CAT) user and, as i said, it worked flawlessly on 1.1

Under Connected to Core, there are three items

  1. System Output, which as i explained before, when i try to enable it, it comes up “Device Not Found”

  2. JRiver Media Center 20 (subtitle ASIO), which shouldn’t even be on the machine as Jriver was uninstalled

  3. Stahl-TekABC ASIO Driver (subtitle ASIO), which, when i try to enable, brings up an error message: error loading device info: DeviceInitFailed

My recollection is that in 1.1, there was a different option for the Stahl-TekABC, which i thought was the driver for windows. . . don’t know what ASIO means, but didn’t see that before.

Bottom Line - i can’t configure per your instruction. . . .

Thanks for your continued patience and help.

Hey @harry_masoni – you can get a basic overview here, and lots more detail here, if you’re interested. The Core is your server, and Roon in this case is a remote.

I’m having trouble finding information about the Stahl-Tek device online, but it sounds a little like the server isn’t seeing the ABC at all. Can you try rebooting the CAT server and the ABC, and maybe unplugging the USB cable, and then reconnecting it. I’m guessing your recollection is correct, and for some reason we’re not seeing the device at all here.

Let me know how that goes. Thanks!

OK Mike,

So i rebooted, unplugged, etc… NOW that other option i was talking about shows up under “Connected to Core”

Stahl-Tek ABC Audio 2.0 Audio (subtitle WASAPI)

This is the one i recall we selected.

So now, Connected to Core shows:

System Output — Zone Name: System Output
Stahl-Tek ABC Audio 2.0 Audio — Zone Name: Unnamed

Both are set to Fixed Volume Mode
Resync Delay is set to 0s, which is what we had set originally and seemed to work fine
I’ve set the ABC to Private Zone, 192/24 max
I have not checked “Exclusive Mode”, although i seem to remember we had that selected originally

Still no sound!!

Yup that’s the one. Excellent.

At this point, the guide I linked above should get things going. A couple other points:

  • I would probably go ahead and disable System Output as well.
  • You’ll probaby want to use WASAPI driver in Exclusive Mode
  • I would not run the ABC as a Private Zone – you’ll want to be able to control it remotely from your iMac and iPad

OK Mike, i disabled System Output under both “Connected to this Mac” and “Connected to Core”

ABC is set to Fixed Volume Control Mode, Exclusive Mode

Still no audio . . .

Can you confirm what you’re seeing in Signal Path? When playback starts, it’s purple?

At the risk of asking the obvious, can you confirm volume is up at every stage along the way? I know Roon is set for Fixed Volume, but I would double check that, as well as volume in Windows, and any volume control in your setup after Roon, meaning in your DAC or amp.

You may want to try enabling the “Set Max Device Volume” setting in Roon as well.

If you’re seeing the Signal Path light and the music is playing, I feel like this is something simple but give it a look over and let me know.


the signal light is green. When i click on it, it shows the zone as green, the Source (subtitled FLAC 44.1kHz 16bit 2ch) bubble is the purple (I guess, looks more like a white star on my screen) and then there is a second bubble below the Source called Output (subtitled AirPlay Streaming)???, which is green

I confirm the fixed vol mode, then confirmed that Windows is full volume, DAC has no volume control, and integrated amp has volume up.

Now i went back to “Set Max Device Volume” and the Stahltek Wasapi driver is no longer shown!!

All very frustrating . . . .

Yeah, I understand. The good news is we don’t plan to change our audio architecture very often, so once we get this working, I think everything should be stable. Bear with me, ok?

Where are you seeing this? Are you on the iMac?

It might be helpful for me to see some screenshots of what you’re seeing here. If you’re on the iMac, try following these instructions, then just dragging the screenshots right into the reply to me here, ok?

What I’d like to see is:

  • Signal Path as described above (expanded, and showing the Green output)
  • Both tabs for the WASAPI audio device, as shown here – based on the above, it sounds like the device may be crashing, so you may need to unplug the USB cable and then reconnect it, or restart the ABC (or the server, if all else fails)

We’ll get this working @harry_masoni so thanks again for your patience.

you bet, Mike. Thanks for YOUR patience.

First off, i had to unplug and reboot again to get the ABC windows driver back.

I am seeing the same screens (audio settings and signal path) on both the iMac and on Roon Remote on my ipad.

Now i’ll try to get these screen shots!

Let me know if that worked!! Maybe at least out of all this i will develop a better understanding of Roon and also learn how to take screenshots!!!

Hi Harry,

It looks like you named your Airport Express Big Rig, which is what you called your Stahl-Tech. Rename the Airport express. It looks like you might be sending music to the Airport instead of the DAC.

Cheers, Greg

These posts are like mini- dramas, we all understand the pain and frustration and are rooting for a solution.

I think Greg may have nailed this one.


1 Like


I renamed the Airport Express and it turned out that, yes indeed, somehow the music was going to the Airport Express!! But further, i still had no sound, because that new name was what showed up at the bottom of the page in the footer that tells you what zone you’re in.

So i DISABLED the airport express, and voila, music began to play!!! I have no idea why this is, but my audio is back.

I wish i understood things better, but can’t argue with the result!!

Thanks all for your interest and help!!

1 Like

Hi Harry,

Great news.

Just so you know, you can Enable the Apple TV as well and send music to it. To switch between zones, just tap or click the current zone in the bottom right of the screen, next to the volume symbol.

That will bring up a list of zones available and you can switch between them.

Enjoy your music.

Cheers, Greg

Thank you Greg - that is a capability that i may have some use for!!

Well, i’ve learned alot today!

1 Like