No Sound after Using Roon in Win10

Core Machine (Operating system/System info/Roon build number)
WIN10, actual roon version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Fritz Box, everything with wlan/wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
AsusOnboard-Sound, but only to provide the audio to the DAC (Pre Box S2 digital)

Description Of Issue

If i start roon, to play music at an endpoint in the kitchen, or playing music on the WIN10 PC (on which i have installed roon/server/rock (normal/first roon installation) i can’t get any sound to work, while roon is started - which seems logically to me. But: After i closed roon (which was NOT in exclusive mode), i can’t get back any sound from other sources (YouTube, Games, Win-Sounds etc). I have to pull the usb out of the dac, and put it in, again. Which is a bit annoying, - as you can imagine. Why is that? Why is WIN10 not switching to “nomal” mode, after roon is closed? Thanks guys <3

1 Like

It looks to me like Roon is switching audio devices in audio mixer settings on your Windows 10 PC. You may want to see what audio devices are available in Windows 10 audio settings and disable some of them and re-enable primary audio device available from your PC through Roon settings .
By the way, check if you can download audio drivers for your motherboard directly from company that produced the motherboard. Do not rely on drivers provided by Windows 10 instalation.

Hi @Chris_Heil,

What kind of driver are you using to play to your audio zone?
Is it to a WASPI / ASIO driver or are you using System Output?

Thanks a lot, PeterL. I already tried that. Makes no difference.
Roons starts with windows, and only after closing roon and doin the annoying cable thing, i can get back to another source. any further ideas ?:wink:
See screenshot

deaktivierte soundgeräte

Hi Noris! Thank you for your reply.
It’s ASIO. See Screenshot. I can’t use WASAPI, 'cause roon is skipping every track, again and again, by using WASAPI - i’ve no ideay why…you? :wink:

I guess the main questions are:
Was this ever working properly?
Is this a new setup?

No. And No :wink:

You aren’t by chance using ASIO4ALL?

1 Like

Hi @Chris_Heil,

Can you try to enable the WASAPI driver for your Pro-Ject box, make sure you have Exclusive Mode disabled (so it won’t interfere with the Desktop Wallpaper app) and try to start playback? If you have issues starting playback on the WASAPI zone, please note the exact local time + date + track you tried to play and let me know this here.

1 Like

It’s hard to figure out whether this problem is caused by Windows 10 or your DAC. Once Roon starts it connects to the last device it was using. I think it releases this device on close. I think DAC is an offender in this case, and as you stated, you have to unplug it to make things work. Switching USB input will not make any difference, neither changing USB cables. I wonder if you DAC has some additional settings. Usually, you should be able to switch audio devices manually

realtek

Thanks again, Noris!
It is 05.11.2020 , 18:19H; CET / Berlin Time
Track Minimum: Intervals / Ben Caplan
See screen :wink:

1 Like

Thanks for your reply,. Rugba.
No - i did not even know that somethling like that exists :wink:
Should i try it?

Hi PeterL and thanks again!
As all other outputs are not connected to a cable,
the pc just shows me my dac (via USB)

BUT: I found a solution (for youtube at least) with the ASIO connection:
After closing roon, i have to close my browser or refresh a tab …and voila: Works!
I guess it is not the best workflow…but at least an working option.
Better then the cable trick! Thanks for pointing me into a right direction :smiley:

1 Like

This is interesting and it makes sense. Roon is a web app and they do have access to various PC resources. It could be browser’s fault. I do not know which browser are you using, but you should try different browsers and see if there is any difference in behavior.

1 Like

Hi @Chris_Heil,

Thanks for letting me know the timestamp!

I’ve activated diagnostics mode for your account and what this action would ordinarily do is upload a log set to our servers, however I’m not seeing this report arrive.

Can you please use these instructions to send me a manual log set from the Core you used with the above timestamp?

Any issues accessing or sending logs, just let me know!

Hello Noris.

Done, sent you a message & dropbox-link.

Cheers & Thanks, and enjoy your weekend,
Chris

1 Like

Thanks for sending the logs @Chris_Heil, I can confirm receipt! I’ve requested some feedback from our technical team regarding your logs, as soon as I have that, I’ll let you know!

1 Like

Hi. I have the same problem.
Was a solution found?

In my case the sound is lost if i am exiting Roon after playing a file with a different sampling than 44.1k.

Thanks.