No Sound From Apple TV


I’ve set up my Apple TV as a new zone. No issues setting it up, but when I play a music file to the Apple TV, I get the following error: “Transport: Playback has failed due to unexpected error communicating with audio device”.

I’m using Roon Version 1.3 (build 233) stable (64 bit) running on a Windows 10 Dell laptop. My music is stored on a WD60PURX 6.0TB external hard drive plugged into the Dell Laptop. I have 45K tracks.

My Apple TV is a 3rd Generation, Model A1427. It is running Version 7.2.2 (8015). My laptop is plugged into a Netgear Nighthawk X8 router. My Apple TV is wirelessly connected to a Eero Wireless Access Point which is hardwired via Ethernet cable to the Netgear Nighthawk X8 router. I’ve disabled the “Require Device Verification” setting (set it to “Off”) on the Apple TV.

I have tried playing multiple files (Tidal, 16/44.1, 24/96, 24/192, DSD) and get the same error each time. The file attempts to play for about 10 seconds, but then stops trying to play. When I play the files to another Zone (SOtm sMS-200), the audio plays with no issues.

Any thoughts on what I should do?

My Apple TV is Version 3 and not running tvOS 10.2. Your post implies that issue is a result of 10.2. In that post, people who have Apple TV 3 are indicating that their units still work fine. So, it would seem that I have another issue here.

Yeah, that should work.

At the risk of asking you repeat yourself, I would double check the device verification stuff, and maybe even try resetting the Apple TV to factory defaults, if you’re up for it.

Otherwise, @support can take a look at your logs. Instructions for sending them over are here.

I restored the Apple TV to factory defaults and it still has the same problem.

I sent the link to the logs directly to your account.

Thanks, we’ll take a look.

Another test you might try in the meantime is connecting the Apple TV directly to the Netgear (wired or wireless), even temporarily. That would be a good test to help us determine whether the issue lies with the Core, the Apple TV, or the network configuration. If that works, we know this is related to the Eero.

I connected the Apple TV via the Netgear wirelessly and it worked! The problem is with the Eero. I can probably just use it this way, but the Eero has better signal strength in the room with the Apple TV, so if you have any ideas on how to solve the problem that is apparently with the Eero, please let me know. Thanks.

I was going to suggest a network issue but seems you have found it is - not sure but wifi should support the minimal 48K needed for airplay. Sorry no idea what an Eero is but sounds like its no a name brand of AP or extender - at least not one I have ever heard of before.

@wizardofoz google search

The world’s best-reviewed WiFi system…well I wouldn’t put money on that as in my part of the world its a long way to a store. Like I said I never heard of this brand and I’m a networking guy. I have been building networks for clients for many years. I’ll stick with my Ubiquity Unifi I think.

@wizardofoz I worked in support on commercial networks for 26 years, never said it was good just pointed out what it was.

I guess all this banter is not really helping the OP much, but sure sounds like some network related issue messing things up.

As the other wifi worked, maybe a hard reset of the Eero might be worth a shot. I’ve often seen rather strange issues within consumer switches and the like were routing tables get overflowed or other issues where a hard reset can fix things.