No sound from MQA files with HQPlayer

(Tom Keenan) #1

Core Machine (Operating system/System info/Roon build number)
Mac Mini late 2014

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Orbi modem/router combo plus 1 satellite; Mac Mini (running Roon Core) is connected by ethernet to router; Node 2i and Amp is connected to Orbi satellite in another room with Wifi backhaul.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Bluesound Node 2i streamer connected by analog and coax to Peachtree Nova 150 integrated amp with DAC.

Description Of Issue
I’m trying out HQ Player.
I have it working fine as a Roon endpoint … except when I try to play MQA files. The controller seems to work; Roon indicates the file is playing.

However, I get no sound output. I’ve diddled with many HQ Player settings, but no luck.

Any suggestions for how to trouble-shoot this? I feel like I’m just working randomly on a trial-and-error basis (with insufficient knowledge to choose settings systematically).

MQA Files will not decode sometimes
#2

Hi Tom,

Do you mean you can get Roon + HQPlayer working with non-MQA files?

And it’s just MQA file playback that isn’t working?

Can you share as many screenshots as possible, of your Roon audio and zone settings and your HQPlayer settings.

Screenshots helps to see what you’re seeing, otherwise it can be ‘needle in a haystack’ hard to find the issue.

#3

Also, are you trying to use HQPlayer and play to your Node 2i? That won’t work unfortunately. The Node 2i is ‘Roon Ready’ but not compatible with HQPlayer’s protocol (NAA).

From the setup that you describe above, the way to test HQPlayer is to connect your Mac Mini to your Peachtree’s USB input, with a USB 2.0 male Type A to male Type B (printer) cable.

(Tom Keenan) #4

Yes, I can get Roon + HQP working with non-MQA files. It will play to the Node 2i (labelled “Living Room” below)

Current settings attached (but I’ve tried many others).


1 Like
#5

Can you change your ‘Vol Min’ to -12dB and your ‘Vol Max’ to -6dB.

Change both PCM filters (1x and Nx) to “poly-sinc-short-mp” (just to test).

Change PCM sample rate limit to 192kHz.

Leave ‘default output mode’ as PCM for now (for testing).

Try again?

(Tom Keenan) #6

Tried all those changes, Sean. Still no sound.

I wonder if using “Core Audio” as the backend is an issue? My Mac Sound preference setting is set to “Living Room”, which is my label for the Node 2i. But how does the signal get over from the Mac Mini in one room to the Node 2i in my Living Room? Would it be an Airplay connection to the Node 2i … in which case non-MQA files work, but MQA does not??

#7

I mentioned above:

"Also, are you trying to use HQPlayer and play to your Node 2i? That won’t work unfortunately. The Node 2i is ‘Roon Ready’ but not compatible with HQPlayer’s protocol (NAA).

From the setup that you describe above, the way to test HQPlayer is to connect your Mac Mini to your Peachtree’s USB input, with a USB 2.0 male Type A to male Type B (printer) cable."

I’m not sure how you are playing Roon + HQPlayer non-MQA stuff to your Node 2i. It isn’t possible.

Are you sure it’s not just Roon alone playing to your 2i?

Can you show your Roon Signal Path, when you have Roon + HQP working with non-MQA files, to your Node 2i?

(Tom Keenan) #8

Here is the Roon signal path when I play a non-MQA track with HQP selected as the endpoint.

#9

This signal path results in sound coming out of your Node 2i and into your Peachtree?

(Tom Keenan) #10

Yes. I hear it loud and clear.
Is HQP sending output to the Mac Mini, then the Mini is handing it off via Airplay to the Node 2i? In that case, will non-MQA files (but not MQA files) be rendered correctly by the Node 2i?

#11

Now I follow - yes I think that’s what’s happening.

HQP can’t play to direct to your Node 2i (reasons mentioned above) but it certainly could in the way you describe above, via Mac Mini’s Airplay 2 output.

The best way to test HQP is to connect your Mac Mini to your Peachtree with USB 2.0 cable.

Or you can get a small, low powered HQP endpoint (called Network Audio Adapter in the HQP world) and leave your Mac Mini in the listening room (like you’re doing with Roon).

Before buying anything new though, I would move the Mac Mini (temporarily) to your Peachtree, just to test HQP. It’s a pain in the bum I know to move stuff around but it will cost you nothing. Then if you really like the SQ of HQP, then you can get a little HQP endpoint (NAA) next.

Just a friendly suggestion.

(Tom Keenan) #12

Thanks! Maybe later today I’ll try moving the Mini.
In fact, I used to have it co-located with the Peachtree and connected via USB. But input from this forum suggested it was better to separate the Core machine and have a dedicated endpoint (such as the Node 2i).

1 Like
#13

Yep, I agree with this too. But I’m trying to save you some $ first, just for the temporary testing. And Node 2i doesn’t support HQP NAA protocol.

Can separate server and endpoint later, with a HQP NAA purchase. They can be affordable Raspberry Pi based solutions or more expensive options like Sonore microRendu, but other options in between too.

Something like a microRendu (just one example) is both ‘Roon Ready’ and a HQP endpoint too. And will support higher sample rates over USB than your current digital coax connection.

Let us know how you go with testing.

(Tom Keenan) #15

OK, I moved the Mini, hooked it up via USB to the Peachtree … still no joy at first … but, then, bingo!
I stumbled onto something in the settings that made it work. Changing the sample rate to 384K, apparently.

Now, whether HQP is worth the effort still remains to be seen. But at least now I can have at it.

1 Like
(Tom Keenan) #16

MQAs (Prokofiev Romeo & J, David Crosby’s Here If You Listen) sound fantastic.

#17

With which HQP filter?

There’s an MQA-type filter in HQP you can try.

(Tom Keenan) #18

Yes, I’ve been trying closed-form-fast and the poly-sinc-mqa-mp filters.

Now that I have the Mac Mini side-by-side with the Peachtree amp again, I still can’t say I notice problems with the SQ from this arrangement. When music is playing (if ever) I do not notice disk or fan noise. So if I decide HQP is worth integrating, then I might just want to run it off the co-located Mac Mini.

1 Like
#19

Happy to hear the HQP setup is up and running properly now.

Happy testing!

(Tom Keenan) #20

So far, I’m not sure I’m hearing differences between the various HQP filters/settings.

I wonder how HQP works together with my integrated amp, which has its own DAC (ESS Sabre 32 with 24/96 upsampling). Once HQP sends its digital signal processing results into my amp’s USB-B port, isn’t the amp’s DAC coloring these results? Maybe even coloring over any subtle differences among the HQP filter effects?

#21

I was going to mention it yesterday but wanted to let you get it working first… some believe the ESS Sabre chips perform better when fed DSD128 (and up).

And @jussi_laako has shown this is the case, objectively, with certain ESS Sabre chip based DACs.

Even Archimago did with his Oppo 205:

http://archimago.blogspot.com/2019/02/measurements-look-at-hqplayer-325.html

DSD up-sampling is quite CPU intensive.

Give DSD128 up-sampling a try.

You may need to use some of the less CPU intensive SDM (DSD) filters… choose 6144000 Hz SDM sample rate and try poly-sinc-short-mp-2s (just to start)

Change output mode to SDM (DSD).

Make sure you change Max and Min volumes, as suggested yesterday.