No sound from PC & videos won't play after using Roon

Since the upgrade to 1.3 (which I’m very impressed & happy with BTW), I can no longer get sound on my office PC from any software after using Roon. All settings in Roon and on Window 10 are the same, yet MP3 podcasts will not play. Videos on Youtube will not play. Windows systems sound do not occur, etc.

The only thing that “cures” this problem is rebooting the computer, once I do, the PC behaves normally with all sounds, podcasts, videos, etc working. Yet, once I use Roon on this PC (it is not the machine that is running core) again, I get no sound from any media once I quit Roon and I have to reboot once again.

Like I said, all settings are the same in both Windows 10 and Roon as before the update, yet the problem persists. TIA for your help.


1 Like

Hi @7ryder ---- Thank you for the report and my apologies for the troubles here. Can you verify something me, and my apologies for any confusion on my part.

Are you noticing this behavior when the application is closed after use or while the application is still active? If it is indeed the latter, can you verify if you are using “exclusive mode” while using the application and if so I would recommend disengaging it.


Hi Eric,
thanks for your quick reply.

The problem occurs once I hit “play” in Roon - I do get audio/video from other sources when the application is open if I haven’t hit “play”.

Once I press “play” in Roon, I can get no audio/video from any other source when Roon playback is stopped (and the application is still active) or after I’ve closed the Roon application. I have to reboot the machine to get these sources to work.

Regarding “exclusive mode”, this doesn’t appear to be an option for the ASIO driver that I am using - iFi (by AMR) HD USB Audio



Hi @7ryder ---- Thank you for the follow up and verifying that information for me, the feedback is greatly appreciated!

The application is designed to release ASIO drivers after 5seconds of inactivity which for example, is why a user can switch between another application like HQPLayer and Roon without having to do anything special other than hitting “stop”. Can you confirm for me if you experience the same behavior while using the WASAPI driver?


Just tried the WASAPI driver and I don’t have any issues other than the fact that I’m not getting bit perfect playback now using Roon which isn’t the solution I was looking for! :wink:

Hi @7ryder ---- Thank you for the follow up and confirming the results of that test. Both are appreciated and my apologies for the wait here.

We recommend setting your OS’s sound card as the default playback method when you are using the computer for other services (i.e Youtube etc) and using the iFi for playback in Roon. WASAPI will have the option for bit perfect playback as it will allow you to select exclusive mode in your settings. ASIO works ONLY in exclusive mode, which is why the option is not provided in the settings for this driver.

If you do not wish to use built-in sound card as your system’s default output option, when using Roon you will needs to stop playback, wait for 10 seconds (after that time roon release the device), and then engage playback from a different source.


Hi Eric,
I tried using the sound card from my PC (Xonar Essence STX) and using the BNC out for it and, frankly, wasn’t happy with the results. While it did solve the problem with video playback, for some reason, it won’t consistently do bit perfect playback even with the proper settings for the card so I’m back to USB.

Regarding your second paragraph, if you’re saying that Roon will release playback after 10 seconds allowing video playback thru Chrome, this isn’t happening; I still have to reboot the PC to get video playback if I’ve used Roon.

BNC? I am assuming you mean Coaxial.

suppose so - rca out from the sound card, bnc connector into my Bel Canto DAC 3.

Hi @7ryder ---- Thank you for the follow up and sharing the results of the proposed test with us.

The last we spoke you had mentioned using an iFi device is this still the case or has it since been replaced by the Bel Canto DAC 3. Apologies for any confusion on my part.


Yes, I was using the iFi and your advice didn’t work, so I tried using the soundcard and, like I said, it solved the issue with the videos not playing, but wasn’t bit perfect.

I thought perhaps this was an issue with the iFi, so I bought a SINGXER F-1 XMOS USB Digital Interface Module XU208 U8 that I’m using instead of the iFi and have the same issue using the Asio driver. Once I use Roon, I can’t get any videos to run until I reboot the machine.

Never heard a reply on this and still have the same problem.

Hi @7ryder ---- Thank you for touching base with us and my sincere apologies for the long the wait.

Moving forward, our goal should be eliminate as much complexity from the chain of communication first, ensuring everything is working as expected with the DAC using a WASAPI driver and USB to the PC. Once we’ve confirmed that, we can add the additional elements back in piece by piece, so we can understand why you’re getting different results here.

Lastly, would you kindly confirm for me what your baseline setup is, driver(s) being used, and the observations made via this setup.


Hi Eric -
Here’s the lowdown -

I use a Windows 10 computer. Audio is USB out to a Singxer F-1 USB Audio Bridge (basically USB to SPDIF converter) which feeds a Bel Canto DAC 3. The driver for the F-1 is ASIO, they don’t offer a WASAPI driver to my knowledge.

I can use Roon desktop to control other zones in my house (Bluesound) and it doesn’t screw up the audio or video from my PC. However, if I playback on the PC with Roon via the Singxer, then videos do not run and I don’t get any sound after I exit Roon. I have to reboot in order for things to work properly after using Roon for any amount of time (interesting tidbit is I don’t lose this functionality if I use Roon playback for less than a minute).

All other audio output devices on my PC have been disabled, so I think I’ve ruled out conflicts. If you have a suggestion on how to fix this, I would appreciate it, 'cause at this point, I’m thinking the only solution is to add a Bluesound Node 2 streamer and switch to that when I use Roon…frankly I’d rather save some money and get my PC audio working correctly.



Just reading this back, let me make sure I have this correct:

  • iFi (model?) ASIO Driver - Videos won’t play after Roon
  • Singxer F-1 ASIO Driver - Videos won’t play after Roon

  • iFi (model?) WASAPI Driver - Videos DO play
  • Xonar Essence STX WASAPI Driver - Videos DO play

Is that right? Anything going on with ASIO drivers on this PC? Things like ASIO4ALL, JPlay, anything like that?

Can you confirm the driver you’re using for the current, non-working ASIO setup experiencing this issue? Or correct the above if I’m mistaken about anything?

I don’t have the iFi anymore, so don’t need to worry about that and, while I am sure my post was correct at the time (about what works & doesn’t), I can’t go back and verify the iFI stuff.

you are correct about the Singxer ASIO driver and the Xonar driver. I’ve since disabled it (Xonar).

The only other audio device I have on my PC is Streaming Audio Recorder by Apowersoft which isn’t supposed to take over the audio output unless I’m recording something.

Hi @7ryder ----- Thank you for the follow up and taking the time to answer our questions, both are very appreciated!

Moving forward, would it be possible for you to test the following configurations (see below) on another Roon remote device or directly mounted to you core machine?

  • Roon remote (or core) - > USB - > Bel Canto DAC3.

    • Any issues when trying to use Youtube?
  • Roon remote (or core) - > Singxer F-1 - > Bel Canto DAC3.

    • Any issues when trying to use Youtube?

The goal of these tests is to: A) verify if the reported behavior can be reproduce on another device and B) Confirm that there is no “weird” interactions potentially occurring between Roon and other software on your “office” PC.

Looking forward to your observations!

2 posts were split to a new topic: Meridian Explorer 2 Issues