No sound from Ropieee on RPi3B+ and Hifiberry Digi2 Pro

Hiya. Having had success with Ropieee round the house using HifiBerry DAC boards, I thought I’d upgrade my main listening room. I had been using an old RPi1 and the original HifiBerry Digi with PiCorePlayer. But I wanted to be able to group it with the other rooms.

I purchased a new RPi3B+ and a HifiBerry Digi2 Pro and installed Ropiee without any issues.

It appears in Roon fine, tracks look like they’re playing fine in the app, and my DAC detects 44.1 kHz signal. But there’s no sound.

I can group the device with other rooms and those outputs play fine. I have swapped out the RPi3 with another unit but the problem persists. I don’t have another Digi2 Pro to test with.

Ive tried selecting “HifiBerry Digi2 Pro”, “HifiBerry Digi+ Pro” and “HifiBerry Digi+” in the “audio hat” menu.

Volume is Fixed.

Raspberry Pi is “Raspberry Pi 3 Model B Plus Rev 1.3”

Any ideas? If the DAC wasn’t locking onto the signal I’d assume hardware issue, but thought I’d check in here first.

Thanks for any assistance.


Update: I tried the card in a RP4 but that’s not even detected by Roon. I suspect because there’s no sound device: the card is not being picked up properly at boot:
[Thu Aug 5 16:45:19 2021] wm8804 1-003b: Failed to read device ID: -121
[Thu Aug 5 16:45:19 2021] wm8804: probe of 1-003b failed with error -121

Yep, that’s not ok.
Can you switch to the beta channel (you can do that from the advanced tab) and see if that makes a difference?


Thanks Harry.

No luck with the beta either, from the RP4. Same message in the logs. I sent feedback if it is helpful for you: 8ddd4dad5fa9ed63

I’ll try the RP3 with the beta channel also…

This is sooo weird. I had another report so I bought the Digi2 Pro myself. And over here it works like a charm (on a Pi 4). :frowning:

Don’t sweat it, i think the card must be faulty. I tried HifiberryOS on the RP3 earlier and it was doing the same. While I have the card in the RP4 I decided I’d try HifiBerryOS for Pi4 too - this time it does get detected and Roon picks it up - but still no sound from the DAC.

Odd: if I convert to different sample rates, the DAC detects it, and yet: silence.

Last gasp will be putting the card back in the RP3 and trying Ropiee Beta, I’ll send you a feedback whatever happens.

Thanks Harry for looking into it. Ropieee is great, a very polished bit of work. Thank you!

1 Like

As promised, feedback for the RP3 with the Beta software: 7227028900e34104
Although I suspect that if the Digi2 Pro board is faulty the software environment will have no indication that the signal is silent.
Anyhow, cheers again.