No Sound Out out of Benchmark DAC3 HGC connected to Nucleus+ via USB

Just received a newly purchased Nucleus+ as well as a Benchmark DAC3 HGC. Connected DAC3 via USB to Nucleus+ and enabled DAC3 “shows as DAC2” in Roon. DAC3 recognizes signal yet does not output sound to preamp. Flow is Nucleus+>(USB) Benchmark DAC3>(XLR) C22 Preamp.

Tried DAC3 in other system where Node2i is recognized by Nucleus and DAC3 worked fine. Flow is Nucleus+>(WiFi) Bluesound Node2i>(SPDIF) Benchmark DAC3>(XLR) Power amp.

Must be missing something. Any help is appreciated.

Do you get sound from the headphone jacks on the DAC3? Just trying to narrow things down here a bit…

For some reason, my DAC3 HGC shows up as a DAC2 HGC USB 2.0 in Roon. However, it works fine (connected to RPi 4B running Ropieee). What sample rate are you sending to the DAC3?

Thanks for your response. I do not have headphones to confirm is sound will output. The DAC3 inputs blinks if no signal is detected (from what I read on manual). In this case, the USB input light will turn solid when playing from Nucleus.

As far as sampling rates, I have tried multiple to no avail.

Have you tried setting the internal XLR attenuation jumper to -10dB on the DAC3? Out of the box, it can output almost 20V RMS from the XLR outputs (see the first graph and associated blurb):

The C22’s input limit via XLR (according to the manual) is 10V. Is it maybe shutting down due to overload?

EDIT: Have you tried bypassing the C22 and going straight to the power amp from the DAC3 to test the DAC3’s output? With the DAC3 HGC, you don’t NEED a preamp, though I guess you may prefer the “tube” sound of the C22…

No, have not tried that. Will try with setting XLR attenuation jumper to -10db on the DAC3.

I had that same thought and did try going straight to power amp (MC462) from the DAC3 but no sound output either.

Thank you for the ideas.

I bought my DAC3 HGC used and had to adjust the jumpers back to 0dB as it’s feeding a Benchmark AHB2 which is apparently designed to take the very ‘hot’ maximum output of the DAC3.

You can also try to get in touch with Benchmark. They have very good customer support and should be very willing to help you resolve the issue.

1 Like

Thanks for the input guys. I actually just got off the phone with Rory from Benchmark. Excellent customer support. Apparently the issue was setting for volume on Benchmark set-up within Roon was on “Device Volume”. Upon changing to “Fixed Volume” I finally got audio output via preamp/amp. Thanks once again!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.