No Sound Through PC [Solved, Firewall]


I have no sound through my laptop attached as “system output” to my core. No problems with the core through the main listening system. I am pretty sure this is is since build 259 as it worked fine before. There are no issues with other audio software, foobar, vlc, Jriver etc.

Laptop is a Lenova ideapad 510, 1515SK. (i7, 8mg ram, windows 10, 64bit) I have the latest conexant audio driver installed.

Any ideas?

Hi @tripleCrotchet ---- Thank you for the feedback! Can you verify that you do not have any active firewalls or antivirus applications currently active on the laptop? If there are, I would recommend disabling them (temporarily) and confirming if that action triggers a change in behavior.


Thanks for responding @Eric .

Firewall and anti-virus temporarily disabled but no change. In the meantime, build 262 arrived but also no change.

All visual sound cues behave normally. E.g. the waveform. There is just no sound.

Hi @tripleCrotchet ---- Thank you for touching base and providing the requested feedback!

Moving forward, may I very kindly ask you to please provide me with the following screenshots:

  1. Your signal path leaving Roon when you are experiencing the mentioned behavior.

“All visual sound cues behave normally. E.g. the waveform. There is just no sound.”

  1. The Windows volume mixer (example below)


Hi @Eric,

This is the signal path when trying to play ‘system output’ through my laptop:

When I go to settings there seems to be several locally attached sound outputs so I tried enabling them as well. Both the the high definition audio devices and the intel display output. (After experimenting I disabled them again in this screenshot as I like things tidy).

But there is no sound either. In the screen shots you can see both the track waveform and the soundbar and they both ‘animate’ and work normally. There is just no sound.

This is the windows volume mixer. There does not appear to be either a ‘roon’ or a ‘raat server’ device.

Hi Tony,

The System Output you have named “Tony’s PC” is connected to the Core. Are you running the Core on your laptop or do you have another computer called MediaPC running the Core ?

The core runs on MediaPC. That’s where the library is, with all the music. MediaPC is connected to my main listening system. That works fine.

When I am working, or late at night I prefer to listen via the laptop. That also worked fine until build 259. Now there is no sound although all the visual clues such as the waveform and sound bar behave normally.

The Zone named “Tony’s PC” in your screenshot is the System Output of MediaPC, not the System Output of your laptop.

The outputs for your laptop Remote don’t appear in the screenshot. By comparison, this is the Settings/Audio page for my PC Remote:

You can see that the whole “Connected to this PC” section is missing from your screenshot.

I can’t say why that is at the moment. I haven’t seen a situation where the Remote is operating as a Control but not as an Output. I’ll flag @eric for some follow up.

Thanks @andybob,

You are absolutely correct. I hadn’t noticed as I have the system output disabled on mediaPC. mediaPC is connected to the TV in the living room. When I enable it I get sound on the Samsung TV. Not the laptop:

Somewhere since build 259 roon is no longer finding the sound devices attached to the laptop. So as you say I have lost an entire section. Any other AV programs (foobar, JRiver, vlc, etc) seem to find the laptop attached devices. Perhaps @Eric can shed some light?

So, just to be clear, the screenshot you show in this post was taken on your laptop, and not on your Media PC, right?

Yes @Geoff_Coupe, there are 4 different screenshots. They are all print screens from my laptop and not mediaPC (except of course @andybob’s examples).

But I just double checked. I suppose because I only have core attached devices showing up on both the laptop and the mediaPC, the screenshots for both are in fact identical.

In hindsight, I now see that something happened after build 259 that I misinterpreted. I assumed that an annoying consequence of the build was that I would have to re-enable/re-configure all locally attached sound devices on my laptop. But because I have all system devices disabled on mediaPC (I am only interested in a network attached HQPlayer) I couldn’t hear that I was actually enabling/configuring system devices on mediaPC. I simply did not notice that whereas before the build I had two sections (like @andybob), after the build I only had one.

OK, so you have now disabled the System Output on mediaPC? Because your last screenshot is still showing it as enabled, and given the name “Tony’s PC” - which, if I’m understanding things correctly, was at one point the name given to the System Output on your Laptop.

1 Like

Hi @Geoff_Coupe,

I think the confusion is that there should be two system outputs showing on my laptop. One for the remote (laptop) and one for the core (mediaPC).

Prior to build 259 that was the case. At that point I had the system output enabled for the remote (at both windows 10 and roon levels) and disabled for the core (at both the windows 10 and roon levels as I only use a network attached HQPlayer for listening on the main system attached to the core).

After build 259, for reasons we are still trying to establish, roon cannot find the locally attached system outputs on my remote (laptop). I have only realised this is what happened after @andybob’s comments. Instead, on the remote (laptop) I mistakenly tried to fix the ‘disapearance’ of my previously configured laptop system output (which I labelled Tony’s PC) by enabling the system output of mediaPC (at the roon level) because that was the only system output I could see. Of course I couldn’t hear anything on my laptop (because I wasn’t enabling the laptop system output) but I couldn’t hear my mistake on the system output of mediaPC either as by default I disable that (at the windows 10 level).

As an experiment I have temporarily enabled the windows 10 system output on mediaPC and then the core system output I mistakenly (and confusingly) labelled ‘Tony’s PC’ outputs to the Samsung TV to which my core (media PC) is attached. Which is all a very long way of saying that everything is working as it is supposed to do!

The mystery is that we now know that roon is not finding the conexant audio devices on my laptop, although it was prior to build 259, and everything else (windows 10, foobar, JRiver, vlc etc.) currently finds these devices.

Hi Tony,

Have you changed the name of the MediaPC System Output to something other than Tony’s PC ? I think Geoff is wondering whether that name is suppressing a Laptop output of the same name. Try changing the name to Samsung TV or whatever else you prefer and rebooting everything.

1 Like

Hi @andybob, @Geoff_Coupe,

Just to avoid any confusion I have removed the ‘Tony’s PC’ label entirely from the equation, relabelled the core system outputs and re-booted both the core (mediaPC) and the remote (laptop). There is no change.

At the end of the day, roon appears not to be finding the laptop conexant system audio devices.

This is a screenshot of the remote (laptop). No locally attached PC devices are found, only core and networked devices.

This is a screenshot of the core (mediaPC). In this case no core attached devices are found, only PC attached and networked.

OK, then I suspect we’ve got a firewall issue with the RAAT Server on your laptop - that’s why the Core can’t see the audio hardware on your laptop, but also why you can use the laptop as a control point. Sounds very like this issue (and the solution to it):

1 Like

Thanks Geoff,

The culprit turned out to be one of two raatserver.exe firewall entries on the laptop. The private one was allowed but the public one was not.

Once both are allowed roon core discovers all the laptop’s locally attached audio devices. I am not sure how this happened but I suspect there was some kind of interaction effect during the build 259 upgrade process. What I remember is being battered by prompts on both the core and the remote all at the same time and trying to respond on two different keyboards as the upgrade process was happening in parallel on both devices.

In case this helps others, temporarily disabling the windows firewall did not to make a difference in my case. Roon still does not discover the laptop devices and that can lead to the wrong conclusion that the problem is not a firewall issue as happened earlier in this thread. In my case it was necessary to explicitly allow both public and private access to raatserver.exe.

Thanks again, @Geoff_Coupe, @andybob, @Eric