No Text and Unable to access settings after latest Roon Update

Core Machine (Operating system/System info/Roon build number)
Windows 10 PC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Ever since I updated to latest Roon version (don’t know which as I see no text anywhere in program)

Funny thing is all devices I use to access the core work fine. iPhone app works perfectly and controls all my remote devices flawlessly. I just can’t access settings or any control from the core PC.
I am attaching a screenshot to show you what I see. I have tried to uninstall and re-install latest Roon, but I still get this.

Hi @Thomas_Favata and welcome to the forum.

Please be patient , the Roon LAbs is aware of the problem and is working on an update:

Thank you for the quick response. I find it odd that it seems to be “Graphical Capabilities” issue, yet it is text that is not being displayed. Graphics such as album and artist art are displaying fine. Curious…

P.S. This is a Windows issue for me, not Android.

Hi @Thomas_Favata,

This is specific to a certain GPU series on Windows devices that appear to be functioning incorrectly. As noted in the port that BlackJack linked to above, we’ve acquired hardware and are working on a solution for this issue. We hope to have it release in the near future!


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

Thanks to all who worked on this update. All now back to normal after install.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.