No TIDAL Favorites available anymore

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Hi @Matthias_Seither,

So we can better assist you, would you kindly update your original post to include the template information about your setup? Once we understand how things are set up for you we can better understand how to resolve what you’re experiencing.

Additionally, please try the following:

  • Reboot the Core machine
  • Log out of TIDAL in Roon and log back in


1 Like

I‘ve done this incl. deleting the apps from iPad pro and restart all the devices which means iPad Pro 11" and Innuos Zen Mk III Server. After that I have installed the apps again and locked in new in Tidal and Roon which causes always the same message like following:

If I start the original Tidal app I can find all my favorites as usuall.

And I can find all Tidal favorites in Roon when I search them with the Focus selection collecting over “Tidal” as you can see here:

All works fine till this afternoon today and then, I don’t know why, my favorites are mist on Roon. Could it be, that there is a new update in Tidal itself which causes problems with Roon?

Hi @Matthias_Seither,

Thank you for sharing those screenshots and for giving those initial troubleshooting suggestions a try. I noticed that you are seeing an error message at the bottom of Roon asking you to check your Internet connection.

Can you let us know what your router model/manufacturer is? How is the Innuous connected to the internet, is it plugged in directly to the router? If it is plugged into a switch/range extender/powerline adapter can you try plugging the Core into the router directly? Are you able to actually play any TIDAL tracks or does this behavior only affect the favorites tab?

– Noris

So, I’ve tried all versions of internet connectiveties and the problem is still valid. I have tried internet by wireless range extender and internet by powerline. I think it is not the internet that causes this problem because all other possibillities of Tidal over Ronn workes as they should be. Here you can see that Tidal works fine:

To be honest, for me it is a problem that is not logical and it seams that it is a problem transfering the data regarding my Favorites from my Tidal-Account to Roon. Maybe Tidal has something changed and till now Roon is not aware of this changing. Is there someone how has the same problem?

Hi @Matthias_Seither,

Thanks for giving that a try.

I am able to properly load favorites on my end, so we need to narrow down this issue further to just one aspect. I have a follow-up suggestion for you here, let’s try to see if another PC can run Roon as expected and the favorites show up. To do this can you:

  • Create a Backup of your current Roon Database
  • Install Roon on another PC
  • Connect it with the same method that the Innuous Core is currently connected
  • If you already have Roon installed on another PC, go to Roon Settings -> General -> Disconnect to unpair from the Innuous Core
  • On the “Choose your Core” screen, select “This PC” as the Roon Core
  • Login to TIDAL and verify if the same behavior occurs on the other PC

Once we have this info we will have a better idea if this is Core-specific or account-specific.

– Noris

Okay Noris, I will try this next week. I give you feedback what the result was.

I also have this problem lately…favourite Tidal albums do not load in Roon.

If I am in the “Tidal Section " of Roon…” My Favourites" Artists and tracks load but not albums

see below…I have this problem now…didn’t previously

Same here Tidal Favorites is not on my Roon Menu

Thanks…will wait it out…1st world problem :slight_smile:

Hi @Mattkimb96 & @kjwho,

Can you please confirm that this behavior is the same if you reboot your Core and try logging out and back into TIDAL?

– Noris

What a great idea…it worked…all there…some of the best music ever :slight_smile: Thank You

I’ve done nothing special, but now it works as expected.

Hi @Matthias_Seither,

Glad to hear that the issue resolved itself!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.