No Tidal playback on Roon

For some reason Tidal playback in Roon isn’t working. I’m on the latest version of everything. Via Arc I don’t have a problem at all. Albums load fine I hit the playback button and nothing happens.

1 Like


These two screen shots are from the Roon Core.

Fixed it myself. This is a very cumbersome way of having to fix an issue. Also why, when I have to pay a lot of money for a piece of software, is there no Roon employees online in the weekend?

For every on experiencing problems with tidal playback not working try the following:

Go to settings>services logout of tidal. Restart the core then log tidal in again.

Isn’t fixed after all it plays a few songs and then the same problem arises. No more playback. I repeat the whole annoying sequence of login out restarting my core and login in again. And nothing no tidal playback. Roon Support feel free to contact me directly to sort this issue with your expensive software out.

I have moved your topic from the discussion area to #support.

Please add details about your setup so that people can help you:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches), if on WiFi/Ethernet, and if you are using a VPN

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Roon Core Machine

Ubuntu server with Roon server. Running on a NUC11 with 32GB of ram and an i7 cpu

Networking Gear & Setup Details

I’m a security researcher I never tell anyone anywhere about my exact network setup. From a security standpoint this would be silly. The Nuc is hooked up to the internet the way Roon wants it to be.

Connected Audio Devices

I have three Volumio Roon endpoints setup to different audio setups.

Number of Tracks in Library

27594 tracks and growing

Description of Issue

Scroll up a bit for two screenshots. I can’t play any Tidal tracks in Roon, in Roon Arc Tidal playback works as expected. This occurred after the latest updates of everything. If I select a Tidal album and try to start playback nothing happens it just creates a bunch of errors as you can see from the screenshots. I did some trouble shooting already, I’ve determined it’s not a network issue. I’ve tried suggested solutions from other threads. Like loggin out of Tidal restarting the Roon core and then loggin in again this works for a few tracks and then the same problem arises.

As a security researcher you should know that if you rely on obscurity, your security is broken.

Your issue may very well be a network problem, so I’m out

I never said I relied on obscurity. I’m contractually obligated to not reveal it. Which is besides the point the issue arose after the update before the updates everything worked just fine no issue at all.

Well I was going by what you wrote:

Hey @Berry_van_der_Linden,

Following up on this thread, are you still running into playback issues when streaming audio from Tidal?

If so, please take note of the date and time you experience the issue and share it here :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.