No uncategorised genres

I tried to map a genre into its own hierarchy per Danny’s instructions.
As of now I have no uncategorised genres showing in Browse-Genres. The music is there: I can select an album and see that it is tagged with the previous genre that was uncategorised but at this point 90% of my albums no longer display in Browse-Genre. I have restarted Roon, I have selected Library Maintenance and I have rebooted the server. Same results. Attached is a screen shot of the Browse-Genres display.

Can you explain a little more about what you did here Peter?

If you organized your genres to someplace new in the hierarchy, it will appear under the parent genre you choose – for instance, if you chose to make “Classic Rock” a sub-genre of Rock/Pop, you’ll need to be click Rock/Pop to see it.

Alternatively, any genres you map will no longer be displayed in Roon – they’ll be replaced by whatever you’ve mapped them to. For more information about why you would want to use mapping, take a look at this post.

By the way, I noticed a good example for when you’d want to use mapping the other day. I realized a number of soundtrack recordings I own had a file tag genre “Soundtracks”. Roon already contains a genre in our hierarchy called Soundtrack (notice that AllMusic uses the singular word here). While I don’t particularly care whether the genre name is plural or singular, having both seemed messy.

Roon’s existing genre Soundtrack has a description, and was already neatly organized under the top level genre Stage and Screen. On the other hand, the plural Soundtracks genre from my file tags had no value to me, so I mapped it to Soundtrack and now all my soundtrack albums appear in one place, regardless of whether their genre came from the file tags or was retrieved by Roon.

1 Like

Here is the information on what I did: I pick a Genre in Uncategorised…I right click it and go to the edit view…it defaults Parent Genre to Prefer Roon Data…I select Edit and Choose Genre…I enter a label but then I cannot save this change. I see no other alternatives. There is a description section: I select Edit…it shows No Value…I select Paste and it tips in whatever text is in the buffer. I do not see how this gets me to my own Parent Genre for display with the Roon-mapped Genres.
As you can see, I was unable to create a parent for an uncategorised Genre. No data was changed.
The next time I started Roon, all my Uncategorised Genres had disappeared along with the actual Genre “Uncategorised”.
I have restarted Roon, restarted the computer and activated Library Maintenance.
I can access the files through Artist or Album and I can see that my Genres are there, but they do not present in the Genres browser.
At this point I would like to delete Roon and its library data. How can I do that, please?

Are you trying to get to all the albums or artists in a certain genre? If not, ignore me, as I’ve misunderstood your question.

If this is indeed what you are looking for, I think you are misunderstanding our goal with the Genres browser. It is there to browse your genres, not your artists or albums.

Once you are on a Genre page, for example, in your case, the “Jazz” page, you will see information about Jazz in your library, such as a description, some artist and album highlights, and any sub-genres of Jazz you have.

It doesn’t show the complete list of Jazz Artists or Albums, as that would be ridiculous on this screen. You may have thousands and this screen is not built to help you filter that list down, or efficiently explore such a large list. It just shows some “highlights”. To do see the complete list, you can click on “View All Artists” or “View All Albums”, which takes you over to the artist or album browser, with a focus set on that genre.

The majority of my file-based Genres are Uncategorised in Roon.
I keep reading that you can create a hierarchy of these uncategorised genres so that they show up on the same page as the Roon genres. I tried to do what I thought you suggested for a single uncategorised genre and now I am in the worse state of not having any of my uncategorised genres show up. This bug is a show stopper in terms of utility, since I use Genre for most of my access.
Roon is cool but it has no utility for me until hardware vendors come aboard as I use DNLA. I feel that I have spent too much time playing with it and now want to delete it completely. I assume that if I return to try again, it will simply rebuild the Uncategorised Genres from my file tags again. For now I have seen enough and my efforts are frustrated.