No USB output to (otherwise visible and configurable) Benchmark DAC2 [SOLVED]

Am running RoonServer 1.2 on a dedicated Ubuntu 16.04LTS machine (all updates installed). No other apps installed or running. Am controlling via a Macbook.

In audio setup I can configure SPDIF output to my Benchmark DAC2 with no problem. I can also see and configure USB output to it (“Benchmark DAC2 USB Audio 2.0”) - apparently without a problem.

However when I play anything to the DAC via USB all selected music titles rapidly cycle past in the UI and there is no sound. The lights on the DAC also do not indicate any signal is being recieved. Via SPDIF everything works normally. Output to the DAC via USB also works without a glitch from my Macbook

I am a bit stumped.

aplay -l gives:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: B20 [Benchmark DAC2 USB Audio 2.0], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

My guess is something isn’t right in the server but my Linux skills are limited and I’m stumped.

Any ideas?


I ever saw this kind of issue in my environment.
Intel NUC with Ubuntu installed connects Bryston BDA3 via USB.

My solution are trying follow steps:

  1. Power cycle your DAC
  2. Unplug USB cable from PC side and plug in cable
  3. Restart your Linux machine

Hope this can have some help.

Thanks for the reply, but yes, I have tried all that.

I am baffled as to what to try. I’m thinking of rebuilding the install using Ubuntu server rather than desktop to get rid of as much unecessary software as possible - but it feels like overkill as the Ubuntu PC is only running Roonserver.


I would suggest testing the audio out of the linux box by using one of the linux audio players configured to use the USB port.
Also, I would suggest that you should reboot both the linux box and the DAC after you have connected the USB and see if that works.

Thanks Daniel, that’s a good idea, I will try that.


Interesting . . .

Put some music on the Ubuntu desktop and played it through the default music player . . no sound until I selected the Benchmark DAC in the sound panel of system settings.

Once this was done, Roon output (via USB) began to behave normally too.


Glad you got it sorted. Although I don’t remember having to do that step when using Ubuntu Server 15.04.