No way to update/install roon server

Hi guys,

I have a QNAP NAS, the latest firmware, and tried to update the Roon server. Whatever I do, it didn’t work. After several attempts, I removed the server. Then I downloaded different versions of the Roon server from QNAP.

The first RoonServer_2020-07-15_x86_64 did not work …

RoonServer_2019-06-09_x86_64, same result.

The installation process starts and hangs at 50%. After 45 minutes it stops with the following error message…

Roon 00

Any ideas? Problems with the Roon Labs website?


Is your network set up right? does the NAS have it’s gateway and DNS correctly configured?

Yes everything is correct, NAS works since two years without problems. Just with Roon Server is a problem now

For the “RoonServer_2019-06-09_x86_64.qpkg” I got a different message now…!

roon 00a

Which makes sense because its already outdated.

Hi @Manfred_Egger,
I double checked the installer (2020-07-15) again and had no issue installing it.
When the installation is at about 45%, it downloads the latest RoonServer files for linux from the websites. If this fails, it will write this accordingly to the log file.
I’d also recommend to check your internet connection (especially DNS settings) as @David_Crosbie1 recommended.
You can also try to use Google DNS ( and in your QNAP Interface settings and check if this solves the issue.

I have the same issue here. It stopped at 45%. I am pretty sure that no issue for my Internet connection.

Another explanation could be a slow connection to the file, which is downloaded during installation. I have noticed this a few times (mostly) with users from China.
If this is the case, there is another option to install Roon Server:
Download the Roon Server (x64) application for Linux manually and put this file in your Public shared folder of your QNAP (do not rename or extract the file. The filename has to be RoonServer_linuxx64.tar.bz2 !).
Run Roon Server installation from the QNAP App Center again.

1 Like

Thank you Chris, this was working ;-).