Node 2i Airplay Issues (Ubiquiti Edgerouter with mDNS for transparency)

Hello @noris and @Aaron_Turner

Thanks for reading my note. I have exactly the same problem.

e.g. the Node 2i supports airplay and raat

On raat it works smooth, airplay does not work because of wrong IPEndPoint

8/29 22:54:25 Info: [airplay] AirPlay device connection failed to: AirPlayDevice[DeviceId=90568240B34A@Player._raop._tcp.local, Name=Player.local, Model=NODE 2i, IPEndPoint=]

Is there any solution on the topic?

Thanks for any response.

BR, Flo

Hey @Flo,

Welcome to the forum! Can I please ask that you use this thread as a guide and provide more details regarding your setup?

Does Airplay via iTunes or an iOS device work properly to the Node?
Are you using the latest firmware available in the BluOS app?

Hello @noris

Thanks for your #support.

Here is the situation. I have two networks

192.x for private devices Laptop, server, iphone, etc.
10.x for IoT devices e.g. TV, Node, etc

I leverage an Ubiquiti Edgerouter with mDNS for transparency of the two networks

What is working:
Airplay: iPhone/iPad (private) to Node (IoT) or Denon AVR (IoT)
Airplay: iPhone/iPad (private) to LG TV (IoT)
Streaming: LG TV(IoT) from server (Synology 720+)
File Access in all directions
ChromeCast: e.g. Amazon App on iPad (private) to ChromeCast Ultra in LG TV and AVR

Roon Core runs seamless on Synology DS720+ (private)

What is working:
Roon Remote iPad (private) -> server (private) -> Chromecast (Iot) or Node i2 (IoT)
Roon Remote iPad (IoT) -> server (private) -> Chromecast (Iot) or Node i2 (IoT)

What is NOT working:
Roon Remote iPad (private) -> server (private) XXX Node 2i (IoT) or Denon AVR 3500 H(IoT)
Roon Remote iPad (IoT) -> server (private) XXX Node 2i (IoT) or Denon AVR 3500 H(IoT)

From the Roon Log File:

08/29 22:46:03 Info: [airplay] AirPlay device connection failed to: AirPlayDevice[DeviceId=0005CDC862DE@Denon._raop._tcp.local, Name=Denon.local, Model=AVR-X3500H, IPEndPoint=]

08/29 22:54:29 Info: [airplay] AirPlay device connection failed to: AirPlayDevice[DeviceId=90568240B34A@Player._raop._tcp.local, Name=Player.local, Model=NODE 2i, IPEndPoint=]

It seems for me for some reason Roon Core has the wrong IP Endpoint using Airplay protocol. is the IP of my Router.

Besides mobile devices, all devices leverage Ethernet cables.

Latest BluOS and BluOS App are installed. No issues with BluOs and BluOS App.

BR, Flo

FWIW, sounds like your network config is similar to mine (the use of a USG and multiple VLANs) but also different from what mine looked like (my server running the Node was on both VLANs and I wasn’t using mDNS forwarding on the USG).

I’ve recently switch to pfSense (USG was no longer meeting my needs) for the firewall and using mDNS forwarding and my server is no longer on both VLANs. Gonna give Roon another try I guess although I have to admit I’m a bit concerned that if it breaks again support won’t be able to help me and I’ll be out my $$$ which may keep me from subscribing.

Hi @Flo,

Roon does not support running across multiple subnets, so I have moved your thread over to the #tinkering section.

There’s some users that have gotten this to work, but there’s a fair amount of reading involved / configuration needed and we cannot officially endorse such setups:

For Airplay across subnets I specifically had to open a wide range of ports (TX device to RX device). Once the ports were open then it worked fine. There is no “official” list of which ports Airplay uses (that I could find) so it was a lot of trial and error (and seems to change depending on version of Airplay / iOS being used).

For reference, and I just double checked, part of the MDNS response from the router (forwarding the response from the device) is all of the Services and addresses of the target device; about 16 different RRs from an Apple TV. This is how the transmit device knows how to reach the receive device directly after the discovery is done (one of the RRs includes the A record). It would be worth grabbing a local packet trace and then confirming that entire negotiation is occurring across your subnet boundary. Sounds like something is being blocked by your firewall configuration preventing Airplay from working.

Hello @ipeverywhere

IMHO the ports for Airplay are well documented on the Apple Developer website. Running mDNS on Edgerouter solves the problem on port management.


I get your point on subnets. Where are exactly the limitations? Can I run two networks in 192.X.X.X IP range? #support Second, as mentioned, an iOS device on my 192.X network can connect easily to any airplay device on 10.X network and stream video and audio.
As mentioned, RAAT works seamless from 192.X and 10.X networks and the other way round.

I am sorry to say, in 2020 any software should be able to operate in a multi IP set up. If people spent a premium price on Roon, hardware, audio equipment etc this is slightly a challenge.

BR Flo

Hi @Flo,

While some users have gotten Roon to work over multiple subnets, having this kind of configuration in place is not supported at the present time.

You can certainly open a feature request regarding this capability, but we cannot comment on when/if this feature request would be implemented.

If you check my thread in the Tinkering section I explain how I got Roon to work across subnets/VLAN’s. I use pfSense, but if you’re tech savvy you should be able to get it working on an EdgeRouter. Where savvy == knowing how to compile a C program for Linux/MIPS64.

That said, without official support this “hack” could break any time Roon changes their networking API. I have no idea how (un)likey that is.

Alternatively you might be able to get it working if you can figure out the magical firewall/NAT rules to forward UDP/9003 broadcasts across networks. Maybe a 1:1 NAT?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.