Node 2i not recognized

Core Machine (Operating system/System info/Roon build number)
Windows PC, Bluesound Node 2i

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
WiFi, Asus router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Roon communicated wonderfully with my Node 2i for several months. Now it doesn’t. Tried rebooting router, PC, Node 2i. No difference. Node 2i doesn’t show up in the devices connected in Roon on my PC. Roon will play through my PC (using an NAD amp) but it no longer recognizes the Node 2i. The Node 2i is working fine (using the Bluesound app on my ipad, to play radio). Any help appreciated.

Check Roon Ready is still set in the 2i settings.

Sorry to be thick, but where would I find the 2i settings?

It should be part of the BlueOS setup so you need their app and then find settings. Check Roon Ready is enabled.

Still thick here. I have the BlueOS app. Can’t find anything in settings re: Roon Ready.

Hello @Michael_Grande,

Here are some troubleshooting steps to get you started:

A) Disable the Windows Defender firewall as well as any other firewall functionality that may be included in an antivirus suite.
B) After disabling the firewall, reboot the Roon Core, your router, and the Node 2i.

If this does not work, please report if you can see the Node 2i under the AirPlay tab in the Settings > Audio screen.


1 Like

Disabled the firewall, rebooted all components. Roon will briefly recognize the Node 2i, play two or three seconds, and then disappear. Or it will look like it’s playing in Roon but no sound on my system. Or I can hit the play icon on Roon and nothing happens - no sound, won’t play, just sits there. Checked all my connections. The Node 2i shows up intermittently in the AirPlay tab . . . .but not in the system output area.

Hi @Michael_Grande,

Can you please try connecting both the Node 2i and your Core via Ethernet to your Asus router? Is there any change in behavior if they are connected this way? What is the exact model of the Asus router you have? Have you made sure to enable “multicast routing” as per our Networking Best Practices?

I purchased a new router - I’m now using a Netgear Orbi. I’ve disabled IGMP Proxying. Connected the Node 2i to the Orbi satellite unit. Working very well now. Thanks for your help. If things crap out again, I might write back. Michael

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.