Noise on DSD up-sampling with a Vega Dac

Hi, I’ve been trying the DSD up-sampling feature within roon. On the first track played I always get a hissing/interference noise and sometime a feedback sound. I then need to stop the track and select another, this often fixes the issue within the next few plays but starts again the next time I wake up the DAC.

I’m using an external thunderbolt drive > iMac > micoRendu > Vega Dac (latest software)

My Roon settings on the Sample Rate Conversion are:
Sample Rate Conversion – DSD
DSD Sample Rate – DSD128
Sample Rate Conversion – Minimum Phase
Sigma-Delta Modulator – Tried both 5th Order (CLANS) and 7th Order (CLANS)
SDM Gain – 0db
Parallelize Sigma-Delta Modulator – OFF
Enable Native DSD Processing - ON

All other setting on the DSP Engine are disabled.

Hoping there’s a simple solution to fix this?

Try turning parallelize sigma-delta modulator on. This spreads the CPU processing over all cores rather than just one core.

Thanks I’ll give that a go.

Unfortunately, I still get the noise coming through on the 1st track when the parallelize sigma-delta modulator is turned on.

Hi @Paul ----- Thanks for the feedback and sharing your observations with us, both are appreciated!

Moving forward, to help aide in my evaluation of this behavior you are reporting to us, may I kindly ask you to provide/verify the following information for me:

  1. Can you please expand on description of your current setup as seen here.

  2. Please provide the following screen shots:

  • The signal path leaving Roon when you notice the hissing/interference noise.

  • The device settings being used for the MicroRendu + Vega DAC zone. This information can be found by going into the audio tab, clicking the gear next to the desired zone, and selecting “device setup”. Please be sure to provide screenshots from all three tabs: “General”, “Playback”, and “Zone Grouping”.

  • Screenshots of your DSP engine settings.

  1. If you were to not use the DSP feature in Roon and play some DSD 128 content, what is the experience like? Do you still receive the same results?


Hi Eric, Thanks for looking into this for me. As requested please find below a bit more info:

Roon Version 1.3 (build 234)
Operating system: OSX 10.12.5
Computer: iMac Late 2015, i7 with 32GB Ram.
Music is stored on a CalDigit HD attached to the Mac via thunderbolt 2. I import songs via a watched iTunes folder.
I have 2 Zones - one connected in the office to a Weiss DAC (not DSD compatible) and the other a Vega Dac connected by a long Ethernet cable to the micoRendu which is connected to the Vega dac via USB.
Roon track size: approx. 34,000 tracks.

I don’t own any DSD files so just tried downloading a free DSD64 track by David Elias to see if I get the same results but noticed that iTunes convert’s the .dsf file into a aiff file on import? Is that normal?
Could I get round this by dragging the .dsf file directly into the watched folder rather than importing the track into itunes first?

Hi @Paul ----- Thank you for touching base with me and providing the requested feedback, both are very appreciated!

Moving forward, I would (for now at least) avoid importing the DSD64 track into iTunes and setup a test watch folder in Roon pointed to the newly downloaded media. Let’s leave iTunes out of the equation for the moment.

Furthermore, and my apologies as I should have requested this in my initial post :dizzy_face: Would you kindly provide the MicroRendu settings being used by accessing the device via


Hi Eric, just tried playing the DSD64 track and I get the same noise. In fact, the feedback type sound continued this time even when the track was stopped.

Hi @Paul ----- Thank you for the follow up and more importantly giving the proposed test a shot. Having that feedback is very appreciated.

Just to make sure that we are on the same page, the test you conducted with the DSD64 content was without the DSP engine active, correct? Furthermore, and this may be a bit of a stretch but I am curious as this would be a good data point for us to have. In the interest of isolating some variables, during your troubleshooting have you tried by passing the Rednu and playing out to the DAC via USB from the machine hosting your Roon core?

Lastly, upon looking at the screenshot of your DSP engine settings again, I noticed that just out of the screenshot we are not seeing what “Enable Native DSD Processing” is set to. If it is currently active, would you please disengage it and confirm if you are hearing the issue.


Sorry forgot to disable the DSP engine when playing the DSD file. Tried again with it off and the DSD file played perfectly.

With the DSP engine back on, Enable Native DSD Processing off (usually this is on) the same noise/feedback happens when up-sampling standard aiff files.

Haven’t tried bypassing the microRendu yet.

Hi @Paul ----- Thank you for giving the test another go and sharing your results with me. The follow up is appreciated!

Ok, that’s a good data point. Being as we are seeing this behavior when upsampling to 128, can you confirm how things behave if you upsample to DSD 64, now that we’ve confirmed that a DSD 64 file will playback as expected.


Hi Eric, finally had time to do some more testing:

When I up-sample to DSD64 all is good. After up-sampling a few tracks I switched back to 128 which also plays fine until the DAC goes to sleep then noise reappears with DSD128.

I also tried swapping my Weiss DAC with the Vega in order to bypass the MicroRendu with a direct connection from my Mac. DSD128 up-sampling plays perfectly right from the start!

Does this mean the problem is either with the MicroRendu, long Ethernet run (approx 35/40 meters) or could the airport extreme interfere where the Ethernet cable runs into before going into the MicroRendu?

Many thanks,

Ok forget my previous post the feedback noise is now coming from the Vega DAC connected directly to my Mac :frowning:

Hi @Paul ----- Thank you for the follow up and sharing the results of your testing, both are very appreciated!

Ok, so now with the Vega DAC directly connected to your core machine you’re still hearing “noise” when you upsample. A few things:

You’ve mentioned the following in your follow up:

“When I up-sample to DSD64 all is good. After up-sampling a few tracks I switched back to 128 which also plays fine until the DAC goes to sleep then noise reappears with DSD128.”

Can you please provide some further insight here in terms of the DAC’s behavior when switching between tracks? Does this (going to sleep) happen immediately when changing tracks? Does it (going to sleep) happen after awhile (which would be my assumption)?

Furthermore, have you tried testing with the “Reync Delay” featured enabled?


Hi Eric, yes you are right in your assumption that the sleep mode on the vega only happens when the DAC is not being used for a while or I manually send it to sleep if I’m not going to be using it. Please note when in standby (sleep) mode, The Vega will only shut down some part of digital circuits, keeping all analog circuits on power and the Femto clock active.

Reync Delay doesn’t seem to be helping either.