Noise - ticks and pops on USB (Solved)

I am using Ropiee with display with a USB connection to my Hugo TT on the HD USB input. While listening over my Focal Utopia I can hear some clicks and pops during quiet passages. Sounds like the noise from a vinyl record. I have tried all the USB outputs and they all have the noise. I changed USB cables but no joy. I then used the SD USB input on the HUGO and could not hear the noise. Thinking there might be a problem with the HD input I ran a USB cable from my Macbook (ROON Core) to the HD USB input. Quiet!

I do not use DSP and listen mostly 24/96.

Any suggestions. I really like the Ropiee with the display and would like to continue using it.

Solved:

  1. dual power supplies - noise
  2. Schiit WYRD - still a couple ticks… so probably a power issue or the shared usb ethernet thing
  3. Ordered ALLO Digi One, PI 3 B, 2.5 amp supply. This should solve the noise
  4. Moved the new WYRD to the Core USB connection
  5. Was going to abandon the PI 2, Screen, Ropieee, USB BUT I really liked the screen. Saw another post that gave me the idea to Group it with the Core USB zone. Voila the best of both worlds -Display, control, fabulous sound.
  6. A great learning experience and looking forward to the PI 3 Allo conversion findings

Thanks all for the great advice. PROG on.

I am not a total expert, but my experience is not to use the USB ports on the RasPi as they are described as ‘noisy’.

I don’t know your DAC, but a google picture shows a digital coax connection.

Research the Allo DigiOne or HifiBerry Digi+. These “HAT” boards go on the GPIO pins on the RasPi and produce a great digital signal for your DAC. These connect with digital coax connections.

These are both supported by RoPieee. I have both in different system in our house. My ear prefers the Allo DigiOne, but they are close. I have no clicks/pops/etc.

Maybe others here will chime in as well.

Thanks @Andrew_Callum. I didn’t realize the USB ports were inherently noisy. This may be a workaround. The coax input on the Hugo does up to 24 bit 384khz but not DSD or 32 bit. As I only have a few DSD that should not be a big issue. I will look into it.

S/PDIF coaxial is limited to 24 bit 192 kHz, not 384 kHz.

AJ

I had a similar issue with my Oppo HA-1/rpi3b+/ropiee setup. The wyrd solved it for me. Used a very short (6 inch) usb cable to wyrd and existing usb cable to dac.

Hi @Progisus

Is the Pi3 running on WiFi or ethernet? If Wifi, can you try ethernet?

I’m guessing since you’re using Roon, there’s no USB hard drive attached to the Pi3?

And what PSU are you using? What’s the current output rating? Over 2Amps or lower? Are you using a single PSU to power both Pi3 and Touchscreen? If yes, then is the PSU plugged into the screen or into the Pi3? If it’s plugged into the screen, try powering the Pi3 directly (which then powers the screen).

Hi @WiWavelength Thanks. I was just quoting the specs from the Hugo TT manual but it did make me check the Allo and it is of course limited to 192 khz.

Hi @dabassgoesboomboom

  • the PI3 is running on ethernet
  • there is no hard drive only the DAC on the USB
  • I am using a 2.4a power supply BUT it is shared by the screen through a Y power adapter cable.
  • I will try later today to use separate power supplies for the Pi and the Screen.
  • I also have the power supply plugged into a Homeseer switch module so I can reboot it easily by disconnecting the power. I will also remove that to see if there is a difference.

Thanks for the advice.

1 Like

I’m hoping this is the one that sorts it.

Which soundcard did you select in Ropieee’s settings? Can you post a screenshot?

If this fails, you should consider an Allo USBridge. Much better reliability. But the Pi3 really should be fine for 24/96. It’s the higher sample rates where I suffered the pops you’re having.

With a USBridge (a separate box) you can keep RoPieee Touchscreen as is, for the cool artwork display of course.

Hi @dabassgoesboomboom @stubaggs

Below are couple screenshots of my config. The separate power supplies did not help. I have ordered a WYRD and will give that try. If it works then my few DSD’s may play as well. If not I will add it to the USB connection from my Macbook Core and abandon the PI for now.

BTW - I am using a PI2. Could that be an issue?

Hmm I’m not sure.

I only have experience with the Pi3 and RoPieee Touchscreen and it was fine up to PCM96kHz via it’s USB audio output. It’s the high DSD sample rates where pops showed up for me.

Hello,

I am having the same kind of issues using a Pi3 latest generation connected to a Brooklyn DAC through USB. DSD produce random ticks like vinyl pops. I am using wifi and funnily enough if I try using the ethernet the problem is a lot worse and there is a lot of noise making it unusable.
This happens when upsampling with DSD but also upsampling hires PCM. I tried disconnecting the screen completely but there is no difference. Also I noticed that if I am upsampling to DSD and I move the volume in Roon with no music playing at all I can hear a noise when the volume moves.
What is the best solution to fix this annoying problem?
My DAC support DSD 256 and PCM up to 384 and I would like a solution that maintain the range of the DAC.
Thanks
Marco

Hi @Marcor

I now have 3 Ropieee end points:

  1. Pi3 c/w screen - usb to a DragonFly Red to my AudioEngine 5 for casual listening at the computer - no ticks or ops on that one but it is fairly limited with the DragonFly. If I connect it to the Hugo (below) there is noise.

  2. Pi3 with Allo DigiOne Coax board to Chord Hugo TT to Focal Uptopia’s for intense listening - the DigiOne removed all ticks and pops. I do not use DSP. Very quiet and great sound.

  3. Pi3 - usb to Schiit WYRD to A&K SP1000 (in DAC mode when not mobile) to A&K Rosie iem or Senn HD650’s. This too is very quiet and I think the WYRD has helped a lot here. The WYRD is not that expensive so may be worth a try in your case.

All the Ropiee’s are running wireless with no issues.

Thank you for the info. My system is fine if I stay in within 192, the problems start when I go over the limit. Wireless is fine, ethernet is just not usable due to the noise. I think is due to the fact that on the Pi USB and Ethernet use the same board.
I had a look on line at the DigiOne but I believe that the output is only SPDIF and that is limited only to 192/24.
Good to know you had positive experience with the WYRD because that and the uptone USB regen are my possible alternative solutions. It seems this is the direction I need to explore.
thanks!
M