Noise when playing DFF music

Roon Core Machine

iMac, 3.3 GHz 6-Core Intel Core i5, Big Sur 11.6, 32 GB 2133 MHz DDR4

Networking Gear & Setup Details

Google WiFi, USB connection to DAC and then to AVR Marantz analog input.

Connected Audio Devices

Gustard X16 DAC with the latest firmware.

Number of Tracks in Library

15k Tracks + Tidal

Description of Issue

Twice now I have played a DSD 64 file and got horrible noise. I switched over to JRiver and played the same tract and it was perfect. No problem whatsoever. Example is Ray Charles screen shot attached

Then I played something else in Roon and came back to the DSD tract and this time it was also perfect.

So both times I had trouble … it doesn’t happen if I play something else and come back to it.

What OS is your Roon Core running on? Windows?

Is the Gustard connected via USB?

Are you using WASAPI? ASIO?

Exclusive mode?

Native DSD or DoP?

Not using WASPI or ASIO

I should add this is not repeatable. When it happens it is after I play a non DSD file like FLAC.

My suspicions are also with the DAC itself or possibly the cable (except it never happens with JRiver)

This is another album that gave me trouble. (I just played it again and it is fine)

Hello @Dennis_in_FL,

Thanks for taking a moment to share this occasional behavior.

From what you’ve shared so far, it seems like this only happens the first time you play a track that’s DSD 64. The second time you return to it, it seems to play just fine. Is that so?

Does this happen with all DSD 64 files? You can find just DSD files if you click on the Sample Rate criteria on any view in Focus.

… it seems like this only happens the first time you play a track that’s DSD 64. The second time you return to it, it seems to play just fine. Is that so?

Almost. Yes once the noise starts, I can’t stop it unless I play a non-DSD recording…like FLAC.

But I can’t figure out what triggers it. Although it is only DSD 64 that does it.

I’ve had it happen on three different DSD 64 recordings so far.

I just tried turning off the DAC and quitting Roon and then restarting everything. And all was well…no noise. I tried about 6 or 7 DFF files (DSD 64) and then the same three I got noise on in the past and none of them were acting up.

When I say noise, it is continuous annoying loud white noise that is a lot louder than the music so that the music can’t be heard.

Is there a “handshake” with the DAC that is misbehaving?

These problems started after I replaced the DAC. I had a hardware problem with the new DAC and it was replaced under warranty with another new one. I just noticed my Mac Midi settings went back to default settings with the new DAC and I just now reset it to back to maximum bandwidth.

Possibly that was the issue - I’ll soon find out.

Update: For some reason the Midi settings always go back to the default. It wasn’t the new DAC…it was my MAC…

See the attached screen shot. I can’t change the settings

Update #2: I rebooted the computer and now I am once again able to change Midi settings. Why does my Mac reset it without warning?

And then after playing some DSD 64 tunes, I rechecked the Midi settings and they had once again gone back to the default settings (24 bit 176 Hz) and were once again unchangeable.

This time I quit Roon and once again I could change the Midi settings. I put it at 32 bit 768Hz. Then I played a DSD 64 album and when I checked it — it was back at 24 bit/176 again. However, the display on my DAC indicates DSD 2.82MHz so maybe this Midi setting is bogus?

Roon is changing the bandwidth??? Are my Roon settings not correct?

At the end of the day, maybe this is all a nothing burger…Outside of the first day of the new DAC, I haven’t had any noise issues with DSD. Or maybe I just haven’t repeated whatever caused it.

And I really haven’t changed anything of consequence to “fix it”…so I’m cautiously optimistic.

24/176.4 is exactly what is required to play DSD64 in DoP format.

24/352.8 is exactly what is required to play DSD128 in DoP format.

In the absence of native DSD on Mac, these are the exact rates your Mac OS need to be outputting at, otherwise at any other rate you wouldn’t be able to play them properly at all.

Interesting. I had received advice over at JRiver to put the Mac Midi numbers as high as possible.

I wonder if the source of the noise (first post above) was Mac settings related? I haven’t had any noise since the ugly day-one belches and I haven’t changed anything.

Or maybe my Gustard DAC isn’t handshaking correctly. I don’t get native DSD options in Roon DAC settings. Just PCM, dCS, and DoP. But the DAC display has DSD and the Roon signal path is purple (lossless). Your comment “In the absence of native DSD on Mac,” means – I can’t get native DSD on a Mac? Why not? I get it on JRiver.

I believe I am officially confused.

DoP is a format to carry DSD. You get DSD.

Mac does not offer that.

Try Windows.

How do you know you’re getting native DSD?


you are right…

I just checked my JRiver output and it is also DoP DSD output - not native.