Not able to get Roon working since update 2.0

Roon Core Machine

I’m using a 2010 iMac was running whatever the best MacOS it would use.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

A notice came up I need to update. Since then I tried Linux, on same iMac, and all it comes up with is script, when I try to use auto loader.

I am not really hifi I just listen, which now I can do on Spotify, hate having paid for 4 months more on Roon and updating stops my use of it.

Can I get it to go back to previous version? Tried to read up on it but didn’t understand as my phone is on Roon 2.0 and that seems to make it more complicated

Hi @Richard_Perks,

Let’s get you fixed.

The Mac you have is reporting as below the threshold for the required version to run 2.0. This means we just need to get you on 1.8 legacy versions and do so across the board.

On your Mac, please close out Roon and click my Link here. It should install for you automatically.

On your mobile devices (iPhone, iPad etc), uninstall Roon Remote and search the app store for Roon Remote Legacy and install that version.

Here’s our article about what’s supported along with links and other information.

Please check back with me if you’re still having issues but this should be the fix you’re looking for.


Roon Remote (Legacy) on Apple app store.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.