Not able to login to Tidal anymore

Core Machine (Operating system/System info/Roon build number)
Roon 1.8 build 764

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • Optical fiber internet connection 500Mb
  • Unifi Dream Machine Pro router > Unifi USW-Pro-24 switch > QNAP
  • Wifi network with Unifi AP
  • Most endpoints connected with wire

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • DCS Rossini - UTP
  • Arcam ONE - UTP
  • RPi3 + Allo DigiOne (2x) UTP + Wifi
  • Chord Mojo + Poly WiFi

Description Of Issue
Recently Roon started to give a ‘Cannot connect to Tidal’ error. This has happened before over the past years and could always be solved by disconnecting and login to Tidal again.

Yesterday I tried this but now Roon doesn’t log into Tidal anymore.

The procedure starts properly: login > Tidal page opens > Tidal generates the security token and the browser asks ‘Deze pagina openen met Roon’ (Dutch for: ‘Open this page with Roon’) > the screen returns to Roon but then nothing happens.

The Tidal apps on my phone and iPad work fine.

I’ve tried the login procedure on various devices (knowing that this passing on of tokens can be a bitch):

  • iPhone 11 Pro
  • iPad 12.9"
  • Macbook 12"
    On the Macbook I’ve tried with both Safari and Chrome as browser.

I’m posting on this support channel for the first time, I don’t know what response time to expect. But I’ve seen my issue drop quite fast in this list so I thought I clarify the issue a little further.

My issue is not the ‘cannot connect to Tidal’ message.
My issue is that under ‘services’ I cannot login to Tidal ar all!

It is fully reproducible so please let me know if you would want me to run some tests and make screen captures.

Hi @Albert_Jochems — Thanks for reaching out, and apologies for the trouble here.

Thanks for trying multiple remotes / browsers — That definitely rules out some variables here. Typically, in situations like this when multiple remotes / browsers aren’t working, it means there is some type of communication issue between the Core and our servers.

Often times we’ve found that setting your router to use Google DNS or another public DNS option will result in things working better. If there is no change after that, focusing in on anything running on the Core machine that affects network communication would be good — Try disabling any VPN or firewall temporarily that could be blocking this type of network traffic.

If those suggestions don’t result in any change, I’d like to take a look at the logs from your machine so we can better understand what might be happening. Please reproduce the issue (try to log in to TIDAL) and once it fails to log in, use the directions found here and send us over a set of logs using a shared Dropbox link.


I will check tonight with the DNS suggestion and VPN/Firewall stuff. Although nothing should have changed on that end since I upgraded my infrastructure to the current generation Unifi in January.

I’ll let you know the results!

Well, I ended up in a few hours long search for possible causes in my network.
I started with DNS settings, using Google/OpenDNS/my ISP DNS but nothing helped.
Then I noticed that my Roon server actually wasn’t updated to the last version, although the NAS did report that it was updated! When I tried to force it by choosing this option in the app on the NAS, nothing happened. The NAS log showed that it was not able to download the pkg from the QNAP site.
After quite a bit of time searching and trying I was able to make all of it (updating, Tidal connection) working again!
The step that made it work was to switch the NAS from Manual IP to DHCP. The DNS settings where still the same, only now received through the DHCP server. Only the IP address is different.
I had it on manual because I want the NAS to be on a fixed address. Now I will try to fix this through the network settings in UnifiOS.

Interestingly, Tidal connection was there immediately after I renewed the DCHP lease on the NAS. So apparently the security token was properly passed on to Roon.

Please let me know if anything is unclear. I’m not a network specialist so I might have overlooked some obvious consequences of the Manual/DHCP change that is relevant for the functioning of Roon. I would be happy to provide logs etc. if this helps in your development process.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.