NOT Being Able to Export MORE Than a Couple Hundred Tracks!

Wanting to export the tracks in a playlist, I attached a USB HD to the server. But browsing in the export menu, the hard drive that I connected isn’t seen.

In fact, the PC’s internal music hard drives containing my library aren’t seen either in this (export) function. The only HD seen is the PC’s Windows system drive.

Please advise what it is I’m obviously missing?

@Mrmb, I moved this to the Roon Software discussion category, but if you need support from Roon staff it can be moved to the Support category.

It is not clear what you type of computer and OS you are using for Roon Server, what format drive you have connected, and other information. Can you please provide additional details so others may suggest some ideas?

I neglected to change forums before posting. Thanks for the forum move, Robert F.
WINDOWS 10 DIY HTPC SYSTEM:

  • Mother Board: ASUS ROG Strix Z370-G Gaming LGA1151 microATX for 8th.Gen Intel CPU’s
  • CPU: Intel i7-8700 3.2 GHz 6-Core
  • Case: Corsair Air 240 Mini-Tower
  • Boot Drive (Roon Server): Samsung 500Gb 960 EVO NVMe M.2
  • Pwr.Supply: SeaSonic PRIME 650W 80 Plus Gold ATX
  • RAM: G.SKILL TridentZ RGB Series 16GB (2x8Gb) 288-Pin DDR4 3600 SDRAM (PC4 28800)
  • INTERNAL HD’s (not including the Samsung 500GB System M.2 SSD):
  • One 2.5": 1TB
  • Four: 3.5": 4TB (I think it’s 3.5); 10TB; 16TB & 16TB

The USB External HD I was trying to get “seen” by Roon Export was a 5TB WD “Easystore”. I don’t recall formatting it. So it’s probably NTFS, as are the other internal HD’s are.

Interestingly, Roon Export did show our QNAP NAS and I can log in.

Agree that your Windows system should see an NTFS (or ExFAT or FAT32) drive. I have not used the Export function, let’s see what other users may suggest. We can move this over to Support if that is needed in the future.

I did try both exporting from the Playlist as well as from the basic Track menu seeing if the starting point made a difference. It didn’t. I can’t help think that I’m missing something obvious though!

Presently, I’m Exporting files to the NAS just fine? My Library is on the 16TB HD and the 2TB drives. Yet they aren’t seen/discoverable from the Export menu, only the System Samsung SSD and the NAS are discoverable.

As soon as the NUC and its hardware arrives, I will be installing Rock and moving the Library to a 20TB WD Elements USB HD. I had planned to use Windows Explorer or TeraCopy to move the files from my current 2-Library HD’s, to the one 20TB Elements. That should be an OK move shouldn’t it?

I’ve been following NUC-Rock threads and have briefly read Roon’s Rock documents, along with watching the John Darko “Roon Rocks” NUC-Rock installation video <“Roon Rocks” NUC-Rock Installation Video>. The set-up instructions are specific, well done and they make sense. Hopefully, there will be no hiccups on my part.

BTW, good info. from Mr. Darko and all of the Roon forum gang!!

And all the drives are seen by the system OS? I just tried it and all my external drives on a Windows PC are displayed when I choose the Browse screen for Playlist Export.

Interesting, I don’t know what’s up with my situation?

Also, it looks like I spoke too soon about exporting tracks to the NAS. Export has been stuck on 22 of 238 tracks for over an hour. I just cancelled the export, until I can get the USB HD situation resolved.

I’ve attached 2-pics. One of the HD’s seen on Windows 10 File Explorer and one of Roon’s>Export>Browse menu.
HTPC Hard Drive List

BTW, our Ubiquiti based LAN (Router/24-Port Switch/3-Access Points) has been free of streaming use or any other use since I started the NAS export. The HTPC source is headless and only working on the Export. I’m not sure what’s up with trying to Export?

The first thing that pops to my mind, is the selected folder line in the export screenpic shows the C drive as the selected folder but the folder listing is for C:\User\[Username] which is wrong.

Your reply resulted in a forehead slap!

In the export menu, I’m seeing the Remote PC, NOT the server…Duh!! :roll_eyes: I’m thinking, I’m sending files from my HTPC, so I should see the HTPC’s hard drives…yeah, wrong he acknowledged sheepishly!

I appreciate the hand holding!!

I still don’t know why the server got stuck sending files to the NAS. That was only a workaround though, until I got my head in the game. So, as far as I’m concerned, it ain’t needed, don’t fix it (worry about it). Cheers, -Mike

1 Like

About Export getting stuck. Exactly how many tracks are you planning on exporting

There are 3-Playlists that I want to export. These contain the following track count:

  • 238
  • 1,297
  • 2,590

When I attempted to export to the NAS the track count was the 238. It got “stuck” at 22 of 238. But as I said, that’s not a concern, now that I figured out how to Export locally from the remote PC.

After my above referenced (server>remote>hard drive) euphony, I connect the WD 5TB hard drive to my remote PC and the 238-track Playlist was successfully exported – Yay!! :clap:

However, I only assumed the Export was successful, because actually there is NO Roon confirmation of same!

Because there is no Roon confirmation that the job was fully done, I found the .roonjournal file & opened it with a text editor. Each line contained a track and there are 239 lines – minus the beginning line with no output (track) – I have the 238-tracks I wanted! :slightly_smiling_face:

Thereafter, I attempted to copy the Playlist with 1,297 tracks as I had previously done with the 238 Playlist. A total of 77-tracks were copied, NOT 1,297.

A Roon update prompt was received. So, I updated to the latest version. Afterwards, I tried again to copy the 1,297 track Playlist. It hung for about 45-minutes at track 228 (of 1,297) & I halted the Export process.

I opened the .roonjournal. I found 219 tracks NOT 228 (but that’s unimportant)! The fact that this is occurring is what’s important.

This is confounding:
For Exports, is there some sort of arbitrary maximum, or X number of track limit, before Roon hangs (or just closes without an error message)?

Or did something happen between my remote PC and the USB drive connected to it, that somehow stopped Roon from performing a complete Export?

If the answer is: there is a limited to the number of tracks that can be Exported. What is the Limit?

I’m asking, because I could select the limit (out of the 1,297 needed) and keep selecting that limit number, until the Playlist is fully Exported…

I regularly export 1k+ track playlists so there’s no limit up to that amount.
These are all local files, not Tidal/qobuz?

1 Like

Yes, they are local (my owned FLAC files). They reside on my HTPC which is the server.

No problems have ever been experienced with the Laptop remote. The HD (Hard Drive) connected to the Laptop is a USB powered WD Easystore.

The LAN is Ubiquiti Router, Switch and Access Points. Ethernet connects the HTPC. The Ubiquiti Access Point is directly above the Laptop which is on WiFi. When trying to export, no video was streaming over the LAN – only the Laptop was in use. In over 5-years, I’ve never had any problems streaming/playing Roon files.

So, I’m at a loss, if others are Exporting 1,000’s of files & I can’t!

Would it help to connect a USB drive directly to the Server (HTPC)? If so, could I tell Roon to use that drive for Exports?

Ironically, this was the original problem that began this post. That is, I connected a HD to the Server, blindly supposing that I could use my remote PC to Export files to the HD connected to the server.

Assuming this may remove the LAN from the equation, is there any way to have Roon Export the files on the Server to USB hard drive connected to the Server?? If not, is there something else that I could correct to get the large Exports done? If an Export hangs for over 30-minutes, should I just let it run? Or…???

What is the OS of the HTPC RoonServer?

HTPC/Server OS is Windows 10.

I checked my Library and did have some files that couldn’t be read. I deleted them via Widows File Explorer. I cleaned the Library. I installed the latest version release of Roon.

I presently have Export running to the NAS. I’m about 1/4 of the way through with 383 of 1,297 tracks copied and still running. I will advise if this Export completes.

A Picture says…well…you know!

What gremlins kept it from working previously…I haven’t clue! Perhaps some of what I itemized above – like the bad file deletion I did & the installation of the new Roon version I mentioned – helped. Perhaps I tilted my head a different angle when I hit run this time!?! :wink:

At any rate it worked! :+1: :slightly_smiling_face:

Thanks for the experienced encouragement ged_hickman1!!

4 Likes

I would bet on the bad files as the culprit.

1 Like

I would suspect “bad files” as the number 1 cause also.

I wasn’t aware of the “bad files” issue, until I found it in and among several of this community’s posts.

When “bad files” are on a system, it may be wise for Roon to add a notification to a user, that “bad files” have been found and deleting them would be advisable.

My system has probably had these files since day one. I would often find the blue running circle in the upper right hand (by bookmarks), constantly running. Those files may have been the culprit.

I have an issue exporting anything from my server. Crashes the server section for a bit then it resumes and exports nothing. I have a ticket in but no replies in a week :(. This is to local or external hdd on remote machine. It works for excel and Soundiiz but not the files from my library.

If you haven’t, you might try

Settings>Library>Skipped Files

And see if you have any (bad files) that have been skipped by Roon.

As we’ve said above, there is Roon community anecdotal evidence suggesting (unless they’re deleted), the existence of these files may cause unintended consequences with Roon’s running & functions. At the very least, if any skipped files are found, it’s probably wise to delete them and then perform Settings>Library>Maintenance.