Not converting DSD to PCM - only clicking heard

Hi, all -

  • I have a meridian explorer 2 dac with the latest drivers installed (3.341)
  • I have one zone with one device enabled (Meridian Explorer2 USB DAC audio/WASAPI)
  • I have exclusive mode on with DSD playback strategy set to Convert to PCM since my DAC does not handle DSD files
  • When I play DSD64 files (.dsf) all that’s output is loud rapid clicking even though Roon seems to graphically show the correct audio being played
  • All other audio files seem to play fine with this setup
  • if I switch to the Meridian USB ASIO driver instead it will play DSD files converted to PCM but then they get sampled down to 176.4kHz - shouldn’t I be able to get higher sampled sound and better overall sound quality through the USB DAC?

Thanks in advance for any help - I did a search but came up empty…



Anyone had experience with this kind of issue?

Hi @Eric_Luther ----- Thank you for the report and my apologies for the slow response here. I see you have provided details about your setup, thank you :+1:

May I kindly ask you to please expand on this information a bit and give us a detailed description of the device that is running your Roon core.


Hi - it’s a HP desktop PC (envy model) running windows 10 with the meredian explorer 2 DAC - I’m not at home at the moment but can give more details soon if you need them - just let me know and thanks for the response…eric

Here are some more details
HP envy w/beats audio; H8-1437c
Intel core; i5-3470 CPU @ 3.20GHz
Installed memory 12.0 GB
64-bit OS, x64-based processor
Windows 10 Home (it came with windows 8 but I upgraded to windows 10 before installing Roon - the HP website does not seem to offer driver updates etc. for windows 10 for this model; maybe I should reformat and go back to windows 8/8.1? I only use this computer for audio playback…)

So I reformatted and got it back to Windows 8.1, reinstalled Roon fresh and now I can’t even log on through the program; it asks for my info and then gives me a double “unexpected error” message - help!

I found several important windows to install now that I’m back to 8.1; I’ll see if installing those make a difference

Those updates fixed that problem - now I’m setting up Roon again and am hoping the DSD files play properly…will update later…fingers crossed!

Nope. Same exact problem as described above. Why isn’t Roon converting DSD to PCM? Your support is much appreciated…

This thread seems to also be about this same problem - any insight as to when the referred to fix in the next release will be released? Thanks…

Just to confirm; I used the Tascam hi-res editor to convert a DSD64 file to DSD128 and Roon converted/played it fine - I hope we get an ETA on the fixed software release ASAP…thanks, eric

Hi @Eric_Luther ----- Thank you for the follow up and my apologies for the slow response here.

Based on your last post, and my apologies if I am misunderstanding this, you transcoded a DSD64 to DSD128 and now Roon is playing the content back without the clicking present?


Yes, that’s correct; just as a poster within the link above did. I have many DSD64 files and don’t want to convert them all and am counting on it being fixed in a forthcoming release as mentioned in that other thread…

Hey @Eric_Luther – I just took a look at this and I think there may be an issue with WASAPI and DSD64 here, but the conversion to 176.4kHz sounds like what I would expect when converting DSD64 to a DAC that tops out at 192kHz.

While we look at the WASAPI issue, feel free to use ASIO drivers or set your volume control mode to DSP volume.

Thanks for reporting this!

1 Like

Thanks for the reply…cheers, eric