Not getting anywhere with Ropieee

I’m trying to get Ropieee running on an RPI 4 model B and I’m hitting a wall. When I turn the Pi on, the LED flickers for a couple of seconds, then gives me a repeated 4 flashes. If I turn it off then on again, the LED glows solid for a few seconds, then turns off. The ethernet LEDs are on solid during this time.
I have two cards that I have formatted with Etcher (repeatedly) and I get the same behavior with each. I have also gotten the same behavior when going through the process with Diet Pi and RopieeeXL. I’m not much of a Raspberry tech. Can someone suggest next steps for me?


The first idea comes out is your pi may has hardware issues. Try another one if you has chance.
OR try to use Rufus. Ref info is here.

How long do you wait before you turn the RPi off/on?
RoPieee takes awhile to install; you need to give it time.

OTOH, all these off/on cycles could have corrupted the OS card. You may have to reflash.

Really doubt that there is a hardware problem with the RPi.
Apart from the SDHC card, they seem to be indestructible.

RoPieee is dead nuts simple to install and use.

It’s my understanding that the 4 flashes means it can’t find some boot file that it needs. Should I expect the four flashes to continue throughout the install? If that’s the case, I have been impatient.

If that’s the case then you need to re-flash the card, since that’s where all the files would be.
I also dislike Etcher and normally use Rufus.

Don’t know how long you wait for me to pass judgement on that. :smirk:
I would say if your still have problems after 10 minutes, then the flashes are indicating a problem.

I’ve done multiple flashes on two cards, with the same result on both. I have not waited 10 minutes before shutting down, however.
Should the ethernet LEDs flash during the install? Mine are on steady all the time.

Don’t remember.

My counsel is to (as the RoPieee site advises) go get a coffee, or just wait a little while longer.

From RoPieee’s web site -

RoPieee will boot and configure some final items. This will take some time and during this period RoPieee will reboot a few more times. This configuration period can take up to 5 minutes, so be patient and get some coffee :wink:

After this last reboot RoPieee can be configured as endpoint from within Roon.

As RoPieee is meant to be used unattended (without screen and/or keyboard attached) it uses the green LED as a visual indication of what’s going on. During installation/configuration the green LED will flash at high frequency (10 Hz). When the RoPieee is ready to rock this changes in a flash at a steady 1/2 Hz.

Oh yeah, one other thing. Are you sure Ropieee isn’t sitting in Settings==>Audio waiting to be Enabled?

@spockfish, what say you?

Hi @Charles_Williamson,

  1. How new is this Pi?

  2. is there enough power? As in: are you using the official Pi power supply?

The 4 flashes (the GREEN led I pressume) means it can’t find stuff during boot.
And just to be sure: you have the latest image downloaded from the RoPieee website?


The Pi is a 4 model B newly purchased by me. It came bundled with a power supply which claims to deliver 5.1v, 3000 mA. The version of Ropieee is one I downloaded from their website yesterday, which I believe has a Sept release date. I have tried the compressed version, the non-compressed version and the XL version (and Diet Pi) all with the same result.

Also, I have let the 4 flashes continue now for over 30 minutes. I don’t think it’s doing anything. There is still no activity indicated by the ethernet connector LEDs.

Is it the green led that is flashing?

@Charles_Williamson can you try this image:


UPDATE: I replaced the Pi and now everything is working! I’ve gotten to the point where the LED is flashing at .5 htz, so now I’m moving toward configuration. Thanks for your help with this.

So, a hardware problem with the Pi.

Eating my hat for dinner.

I’m just glad I got it working. It’s now configured and sitting on my WiFi driving a Dragonfly DAC. Everything looks to be seamless! Thanks for jumping in.

1 Like

I’ve configured Pi, loaded ok, updated a few setting through the webpage but I can’t see it in ROON as audio endpoint, any tips to get it to use, I have other multiple end points other than Pi working

Did a bit more digging, i can see it as a audio bridge under about in ROON settings, I don’t have an audio HAT on the Pi, I’m using the USB out, in the Pi settings I’ve selected USB out.

Is it Enabled in Settings==>Audio?

You have your DAC plugged into the Pi, right? It’s the DAC not the Pi that should show up in Roon.

I guess I’m stating the obvious but is not true that an RPi will only show in Roon if it has an active audio output.

Ok, sorry if I have given bad info, I’m new at this. My recent experience was that my Pi did not show up until I plugged in my DAC, at which time my DAC showed up.