Not playing back on Sonos anymore

Core Machine (Operating system/System info/Roon build number)

Roon 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

On wifi using Netgear Nighthawk R7000P

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

15” MacBook Pro 2015 wifi

Sonos devices Play 3, 3 ZP80, ZP100, 2 Play 1

Description Of Issue

Roon no longer seems to be able to control and playback on my Sonos devices. On some it just looks like it’s trying to play songs but it doesn’t (the music time doesn’t go forward at all) and on others it will say it lost control of the device. I have tried to disable and then enable the device again but it still doesn’t work. It worked as of a couple of weeks ago.

This seems related to what I am experiencing:

I only have problems playing back on my sonos. I have Apple products that playback has no issues. I have only tried playing back local files not Tidal or Qobuz.

Ok then it is not what I am seeing. My local files are playing fine but my onine files are flakey. Some play some don’t.

I solved the issue on my own. The Roon Core wasn’t updating where on the network the Sonos players were. I had reset my router a few days ago and in turn all of the Sonos had new Mac addresses. I closed out Roon on my core and restarted it and it found them again on the right Mac addresses and now it works fine.

1 Like

Hello @Jim_Carter, glad things are working again! Please let me know if you have any further questions.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.