Not Ready Roon ARC

Roon Core Machine

Xiaomi Redmi Router AX5400 → LAN cable → Roon Rock (i5 gen10/16Gb/256ssd) → USB cable → Hegel H390.
MB Air M1 OS Monterey, iPhone 13 Pro max IOS15.

Networking Gear & Setup Details

Xiaomi Redmi Router AX5400 → LAN cable

Connected Audio Devices

USB cable

Number of Tracks in Library

Description of Issue

The provider reported that the ip address is static.
ARC works only via wifi.
See screenshots.

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I would leave the core in DHCP mode. If you want to make sure it keeps the address make a reservation in the router. More importantly have you done the port forwarding? 192.168. 28.35 and port 55002

No, I don’t know how to do this (

There is (of course) a YT video


Thanks. You have the best support!

It was helpful fellow Roon user @Bernd_Kurte who provided the assistance here, so thank you @Bernd_Kurte for volunteering your time and expertise.

@Nikolay_Frolov, an alternative to setting the manual port forwarding rule in the video above is to enable UPnP on your router; the diagnostics you’ve provided suggest that UPnP is not enabled or improperly configured. It’s a plug-and-play solution if you only have one router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • If this fails, use the YouTube instructinos above to try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

it worked :sweat_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.