Not respecting USB force volume 100

@spockfish I re-flashed to the latest build 2022.06.3 (I had been running 4.017).

My setup is a RP4 running USB directly into my LS50w (the native roon “tested” functionality for the LS50w sucks)

I noticed that whenever the RP4 reboots the “device” volume is reset to 31. Even though I have the “Force volume” setting fixed at 100 in RoPieee, and I also have the volume fixed in Roon.

If I enable “device” volume in roon, I can manipulate the volume of the sound, even though, this does not actually change the volume setting of the LS50w.

This wasn’t a problem on the older build.

Feedback: 98087a4b3d81adea


Hi Nat,

What I’m seeing in the logs that your DAC/Speakers aren’t connected during start up, but appear later on. As RoPieee only attempts to set the volume control on initial boot, it will fail to do so if you haven’t your LS50w’s connected (and powered up!) at that point in time.


OK, RoPieee is set to reboot every morning early to check for updates, and my speakers aren’t turned on for a few hours later.

Odd that this setup worked fine in the old build.

Yes… that I can’t explain, because this did not change (from a functional perspective). Only thing I can think of that your LS50’s reset to a last known volume setting upon power on and that might be ‘good enough’ for you.

I’m adding this to the list though, because theoretically it would be possible to force this volume setting not only on start-up, but on ‘plug in’ event. That would solve your issue and does not brake functionality for other users of this functionality.

1 Like

Oh awesome! thank you! I’ll be watching the release notes so I can flip back to the old setup.

For now, I will activate the device volume and just make sure it’s at 100 every time I power on.