Not seeing any network devices

Just come to play some music - not done so for some time. I’m on Roon Core 1.5, build 354, 64 bit. It’s running on a Synology DS716+ on DSM 6.2.1-23824 Update 1.

I can see the core from my PC, iPhone etc and play back music to that local device fine. But I cannot see any network devices from the Core - I’m missing the two Airport devices, a Squeezebox Touch etc.

Checking on Fing I can see all the devices fine.

What can I do on the Synology to check outgoing network detection - e.g. firewalls etc.?

Any clues or recommended steps?

Hey @Andrew_Bovingdon — Thanks for reaching out, and apologies for the difficulties here!

Can you confirm the firmware version of these devices? Apple recently removed Airplay 1 support from the Airport Express devices, so devices on the latest firmware are not compatible with Roon.

This thread includes information on rolling back the firmware on yout Airport Express devices:

Check out our documentation on using Squeezebox devices with Roon. If everything appears to be setup correctly then there may be some networking difficulties at play here that we will need to look into.

Can you describe your networking setup, including all networking hardware in use and how your devices are connected?


Have you restarted the core?

1 Like

Yes, restarted numerous times :slight_smile:

Squeezebox issue was with the Squeezebox. It had simply frozen. Reboot and it’s back.

Airport Expresses were on 7.8, so I have dropped them to 7.6.9, but they are still not visible via Roon. I have 2 of them connected to the Synology box, all via wired Ethernet through a gigabit switch. Same as the SB.

I can see them and play music from my iPhone, along with my Sky Q sat boxes.

Thanks for the update, @Andrew_Bovingdon!

After rolling back the firmware did you try rebooting the devices and your Core once more?

What type of switch are you using? Is it managed? What is the main router in use here?

Yes, airports have been rebooted a few times since. Roon has also been stopped and started a few times

The switch is a 24!port 3Com and not managed. I’m using a netgear d7000 to take care of broadband and DHCP etc.

Odd that the SB works fine but the airport is invisible.

Appreciate the thoughts.

Any more thoughts? Currently can’t use Roon in a few rooms and missing it…

Hey @Andrew_Bovingdon,

After downgrading the firmware others have reported that they’re able to use Airport Express devices without issues, so it sounds like there may be some networking issues at play here. Is there any difference in how the Airport devices are connected to the network compared to the SB?

Do you have any active antivirus or firewall on the Core machine? If so, can you try disabling and see if there is any change?


I suspect you may be right Dylan.

Both of the Airport Express boxes are physically connected to the same wired switch as the SB, so can’t be that. They are only used for Roon and Airplay streaming so all the WiFi is turned off on both.

Roon Core is on a Synology DS716+ running DSM 6.2.1-23824 Update 1. I have not installed any additional firewall or antivirus software onto that, but one of the recent updates may have added something or changed some default network settings.

Any Synology experts out there got any ideas for where to look?


Hi @Andrew_Bovingdon,

Do you have open vSwitch enabled on your Synology? If so, can you try disabling and let us know if there is any change?

Not that I’m aware of Dylan. How would I tell? Anything I can run on the Synology to see if it can see the Airports?

@dylan any way to easily check what things could be blocking discovery by Roon?

Struggling to understand why it can see the SB but none of the Airports? My Sky Q box also shows up on my iPhone/iPad as a compatible airplay device, as does the airplay server I’m running on the PC. They too used to show up on Roon but now don’t.

Hi @Andrew_Bovingdon,

I’d like to propose a test here which should help us narrow down where this behavior is stemming from.

If you install Roon on your PC and use it as your Core instead of the Synology device, and have the PC connected to the network in the same way as the Synology, are you able to see the Airplay devices?

Good thought… Swapped to a Roon Server running on the main PC. This is physically next to the NAS and connected by wire to the same gigabit switch as the Synology. All the network devices appear, including the Apple Airport devices and Sky Q boxes, oh and the Squeezebox.

So I then uninstalled the Roon server from the Synology NAS and reinstalled the 2018-03-07 version fresh. All fires up fine and plays music to the PC, but still no network devices - just shows the Squeezebox.

So I guess this means it has to be something on the Synology NAS blocking discovery? What steps does Roon follow to search and locate playback devices on the network? I’m assuming Squeezebox is somehow different from Airplay?

BTW, in addition to Roon Server I have: Surveillance Station, Download Station, Docker, File Station, Cloud Sync, Plex Media Server, Drive, Synology Application Service, PHP 7.0, Universal Search, Moments, oAuth Service, Hyper Backup Vault, PHP 5.6 and Media Server. I have tried stopping most of these just in case. Still no Airport devices. Any likely to cause issues?

Any more thoughts?

Thanks @dylan

Hi @Andrew_Bovingdon,

Thanks for doing that test — It definitely seems to confirm that there is something on the Synology that is blocking the connection here. The symptoms here seem to be consistent with what we’ve seen occur when open vSwitch is enabled. It may be in a different location depending on your version, but on your Synology try checking Control Panel > Network > Network Interface > Manage > Open vSwitch Settings and let me know if disabling this changes anything for you.

Perfect - hadn’t spotted that setting. That has solved the issue - I’m back up and dancing :slight_smile:. Really appreciate that clear guidance @dylan


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.